Bug 106697 - LTC4843-fake_ll not working for QETH device
Summary: LTC4843-fake_ll not working for QETH device
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-09 18:00 UTC by Duane Beyer
Modified: 2008-08-13 21:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 21:06:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fully working, but with P3s (6.94 KB, patch)
2003-10-09 21:59 UTC, Pete Zaitcev
no flags Details | Diff

Description Duane Beyer 2003-10-09 18:00:14 UTC
The following has be reported by IBM LTC:  
fake_ll not workingfor QETH device
Hardware Environment:z/900

Software Environment:RHEL-3 RC1


Steps to Reproduce:
1. Add the fake_ll to the parm in chandev.conf
     Followed the directions in Linux For zSeries and S/390 Device Drivers and 
Installation Commands July 25, 2003 Chapter 19, Enabling OSA-Express QDIO 
devices in Linux for DHCP and tcpdump.
eth0 is the interface used in this case. 
   
add_parms,0x10,0x9A0,0x9A2,fake_ll

2. Reboot the system
3. Start "ethereal" and capture packets for eth0  

Actual Results: 
Capturing on eth0
  0.000000 40:00:40:06:3e:d1 -> 45:10:00:4c:20:99 0x090c Ethernet II
  0.132967 40:00:7d:06:52:a3 -> 45:00:00:28:cf:fa 0x0938 Ethernet II
  0.159949 40:00:40:06:3e:58 -> 45:10:00:c4:20:9a 0x090c Ethernet II
  0.333547 40:00:7d:06:52:a2 -> 45:00:00:28:cf:fb 0x0938 Ethernet II
  0.333580 40:00:40:06:3e:9f -> 45:10:00:7c:20:9b 0x090c Ethernet II

Expected Results:
Packets should have been valid TCP packets.  It appears that the LLC headers 
are still not on the packets.  

Additional Information: I get the same results on both 31 and 64 bit systems.

Comment 1 Pete Zaitcev 2003-10-09 21:57:33 UTC
It's Boeblingen's fault, but I fixed it (*beaming* :-)
See the attached patch.


Comment 2 Pete Zaitcev 2003-10-09 21:59:25 UTC
Created attachment 95089 [details]
Fully working, but with P3s

Comment 3 Duane Beyer 2003-10-10 20:28:52 UTC
Peter,  Not sure what you mean by P3's.   Is that a 390 box. Also, will this be 
picked up in the next release of Red Hat or do I need to go back to Boeblingen.

Comment 4 Pete Zaitcev 2003-10-10 21:23:34 UTC
Duane, please look at the patch - "P3" is a tag for debugging messages.
Final version won't have them, naturally.

I think I can get this into U1.

I also sumbitted it to Utz Bacher for inclusion into DeveloperWorks.
If you are interested helping it to happen, you might want to poke
him for opinion/rejection/acception.


Comment 5 Pete Zaitcev 2003-10-10 21:25:45 UTC
I observe that Utz made himself an account in RH Bugzilla,
let me try to add him to cc: for this bug...


Comment 6 Duane Beyer 2003-10-14 20:51:43 UTC
Thanks for the update, I applied the patch and it is working fine.  I'll nudge 
Utz

Comment 7 Pete Zaitcev 2003-10-23 04:30:31 UTC
Ernie approved, I'm resending for commit now.
I dropped all unrelated fixes (such as dst_link_failure removal).


Comment 8 Pete Zaitcev 2003-11-09 06:28:14 UTC
Modified 2.4.21-4.11.EL
Duane, please test and reopen or close, according to results.



Note You need to log in before you can comment on or make changes to this bug.