Bug 106705 - LTC4846-Networking Device selection screen does not contain enough info to select device
LTC4846-Networking Device selection screen does not contain enough info to se...
Status: CLOSED DUPLICATE of bug 135418
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kudzu (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 15:03 EDT by IBM Bug Proxy
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-10-09 15:03:54 EDT
The following has be reported by IBM LTC:  
Networking Device selection screen does not contain enough info to select device
CONTACT PERSON: Aaron Bolding, 8-3510
Hardware Environment:  p655
Software Environment:  RHEL AS3 RC3

SYSTEM INFORMATION
------------------
HOST NAME or NETWORK ADDRESS: ih15.apt.austin.ibm.com
HMC HOSTNAME: 9.3.117.246

Steps to Reproduce:
1. netboot the machine using netboot.img
2. select nfs as the install source
3. reach the Networking Device screen and try to guess which eth to choose.

Actual Results:
My machine had 10 nics to choose from.  After trying some educated guesses, I
just tried them all 
in order until I found the one I had booted from (eth6, which was the 3rd one
listed in the 
firmware).  Furthermore, after setting up the nic, the installer says it is
"Determining Hostname and 
domain...." but does not produce an error message if it fails to do so.  You
don't know it didn't 
work until after you enter the nfs server and it tells you "That directory could
not be mounted from 
the server."

Expected Results:
Some way to tell which eth is which

Additional Information:
Some other distros provide the model of the adapeter and even the openfirmware
path to the 
device for reference.  RedHat's device selections screen looks like this:

Welcome to Red Hat Enterprise Linux                                             
                                                                                
                   +---------+ Networking Device +----------+                   
                   |                                        |                   
                   | You have multiple network devices on   |                   
                   | this system. Which would you like to   |                   
                   | install through?                       |                   
                   |                                        |                   
                   |                eth0   #                |                   
                   |                eth1   #                |                   
                   |                eth10  #                |                   
                   |                eth2   #                |                   
                   |                eth3   #                |                   
                   |                eth4   #                |                   
                   |                                        |                   
                   |      +----+             +------+       |                   
                   |      | OK |             | Back |       |                   
                   |      +----+             +------+       |                   
                   |                                        |                   
                   |                                        |                   
                   +----------------------------------------+                   
                                                                                
                                                                                
  <Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen      


I know this isn't the highest priority issue going, but it would be really
helpful to customers with 
large, complicated systems to have a fix or even a workaround for this.I agree,
this should be addressed since it'll make large configs easier to install.

I'm moving this over to Service to track with RH.Glen / Greg,
RedHat installer issue.  Please open problem with RH and track.. Thanks
Comment 1 IBM Bug Proxy 2003-10-10 17:31:48 EDT
------ Additional Comments From atboldin@us.ibm.com  2003-10-10 17:30 -------
Oddly enough, I noticed when net installing a p640, the model of the network device is listed on 
this screen.  While it still doesn't help me figure out which of the 6 PCnet32s I should use, at least 
it narrows down the list a bit.  Is this problem restricted to LPAR or POWER4 machines? 
Comment 2 Jeremy Katz 2003-10-13 19:10:05 EDT
We show the model of the network adapter if it can be determined.  What does
`kudzu -p -c NETWORK` show on the installed system?
Comment 3 IBM Bug Proxy 2003-10-14 16:42:21 EDT
------ Additional Comments From atboldin@us.ibm.com  2003-14-10 16:36 -------
[root@ih15 root]# kudzu -p -c NETWORK
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e1000
desc: "Intel Corp.|82546EB Gigabit Ethernet Controller (Fiber)"
vendorId: 8086
deviceId: 1012
subVendorId: 1014
subDeviceId: 0288
pciType: 1
pcibus: 301
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: e1000
desc: "Intel Corp.|82545EM Gigabit Ethernet Controller (Fiber)"
vendorId: 8086
deviceId: 1011
subVendorId: 1014
subDeviceId: 0268
pciType: 1
pcibus: 341
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth2
driver: e1000
desc: "Intel Corp.|82546EB Gigabit Ethernet Controller (Fiber)"
vendorId: 8086
deviceId: 1012
subVendorId: 1014
subDeviceId: 0288
pciType: 1
pcibus: 301
pcidev:  1
pcifn:  1
-
class: NETWORK
bus: PCI
detached: 0
device: eth3
driver: e1000
desc: "Intel Corp.|82546EB Gigabit Ethernet Controller (Copper)"
vendorId: 8086
deviceId: 1010
subVendorId: 1014
subDeviceId: 0289
pciType: 1
pcibus: 601
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth4
driver: e1000
desc: "Intel Corp.|82546EB Gigabit Ethernet Controller (Copper)"
vendorId: 8086
deviceId: 1010
subVendorId: 1014
subDeviceId: 0289
pciType: 1
pcibus: 601
pcidev:  1
pcifn:  1
-
class: NETWORK
bus: PCI
detached: 0
device: eth5
driver: e1000
desc: "Intel Corp.|82545EM Gigabit Ethernet Controller (Copper)"
vendorId: 8086
deviceId: 100f
subVendorId: 1014
subDeviceId: 0269
pciType: 1
pcibus: 641
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth6
driver: e100
desc: "Intel Corp.|82557/8/9 [Ethernet Pro 100]"
vendorId: 8086
deviceId: 1229
subVendorId: 1014
subDeviceId: 01ff
pciType: 1
pcibus: 321
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth7
driver: pcnet32
desc: "Advanced Micro Devices [AMD]|79c970 [PCnet32 LANCE]"
vendorId: 1022
deviceId: 2000
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcibus: 622
pcidev:  0
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth8
driver: pcnet32
desc: "Advanced Micro Devices [AMD]|79c970 [PCnet32 LANCE]"
vendorId: 1022
deviceId: 2000
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcibus: 622
pcidev:  2
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth9
driver: pcnet32
desc: "Advanced Micro Devices [AMD]|79c970 [PCnet32 LANCE]"
vendorId: 1022
deviceId: 2000
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcibus: 622
pcidev:  1
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth10
driver: pcnet32
desc: "Advanced Micro Devices [AMD]|79c970 [PCnet32 LANCE]"
vendorId: 1022
deviceId: 2000
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcibus: 622
pcidev:  3
pcifn:  0
[root@ih15 root]# 
Comment 4 Jeremy Katz 2003-10-16 15:55:39 EDT
Can you install the anaconda package and then do the following from a shell prompt?

# PYTHONPATH=/usr/lib/anaconda python
>>> import _isys
>>> pl = _isys.ProbedList()
>>> pl.updateNet()
>>> for (k, dev, descr) in pl: print k, dev, descr
... 

Even better would be if you could get this from the installer environment (if
you're doing a text-mode install, hitting ctrl-Z should drop you to a shell once
you get the second stage loaded, and then no packages need to be installed)
Comment 5 mark wisner 2003-11-25 00:55:49 EST
------ Additional Comments From khoa@us.ibm.com  2003-25-11 00:52 -------
Aaron - can you provide what Red Hat requested above ?  Since it's been more
than a month already, I'd like to defer this bug with 
resolution "Need_More_Info".  Please re-open this bug when you have more info.
Thanks. 
Comment 6 mark wisner 2003-12-01 16:37:37 EST
------ Additional Comments From atboldin@us.ibm.com  2003-01-12 16:20 -------
It doesn't look like I'll be able to deal with this until after we finish our move.  I'll check into it as 
soon as I can after that. 
Comment 7 Jeremy Katz 2004-06-09 16:13:08 EDT
Any updates here?
Comment 8 IBM Bug Proxy 2004-10-08 16:45:25 EDT
----- Additional Comments From khoa@us.ibm.com  2004-10-08 16:45 EDT -------
Aaron - please verify if this still happens on the latest RHEL4 U3.  If it
does not, please close this bug.  Otherwise, we need to re-open this bug
report.  This bug is almost a year old now, so I assume that it has been
fixed.  Thanks. 
Comment 9 IBM Bug Proxy 2004-10-08 19:16:47 EDT
----- Additional Comments From atboldin@us.ibm.com  2004-10-08 19:11 EDT -------
As I said in my email.  This bug turns out to cover both some issue involving
device numbering and some issue involving the installer's ability to provide
info regarding the types of adapters available.  I know we're still having to
guess fairly often what type of adapters we're looking at, but I'll have to find
a machine that I can reinstall to confirm this and provide new screenshots.  I
should have something for you on Tuesday. 
Comment 10 IBM Bug Proxy 2004-10-20 19:17:45 EDT
----- Additional Comments From atboldin@us.ibm.com  2004-10-20 19:15 EDT -------
Here's a screenshot from a JS20 with RHEL 3 U4.  I'll try this on a larger
machine as soon as possible, but this should indicate what we're still dealing 
with:

Welcome to Red Hat Enterprise Linux
                                                                                
                                                                                
                                                                                
                   +---------+ Networking Device +----------+
                   |                                        |
                   | You have multiple network devices on   |
                   | this system. Which would you like to   |
                   | install through?                       |
                   |                                        |
                   |            eth0 - 14e4|16a8            |
                   |            eth1 - 14e4|16a8            |
                   |                                        |
                   |      +----+             +------+       |
                   |      | OK |             | Back |       |
                   |      +----+             +------+       |
                   |                                        |
                   |                                        |
                   +----------------------------------------+
                                                                                
                                                                                
                                                                                
                                                                                
  <Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Also, I don't know why this bug is in FIXEDAWAITINGTEST.  I don't see a fix in
here anywhere. 
Comment 11 Jeremy Katz 2004-10-20 22:54:08 EDT
U4 is hitting a completely different problem :)
Comment 12 Bill Nottingham 2004-10-20 23:42:46 EDT

*** This bug has been marked as a duplicate of 135418 ***
Comment 13 IBM Bug Proxy 2004-10-21 10:36:36 EDT
----- Additional Comments From salina@us.ibm.com  2004-10-21 10:37 EDT -------
Mark / Stacy / Glen
Can we see the problem Redhat dup'ed this to please.  Thanks. 
Comment 14 IBM Bug Proxy 2004-10-26 17:38:26 EDT
----- Additional Comments From marksmit@us.ibm.com  2004-10-26 17:37 EDT -------
Aaron originally opened this bug on RHEL3 because he could not differentiate 
between network adapters.
In comment #14, he confirms that this still recreates on RHEL3-U4 (1008 isos).

The wrinkle is that in comments #15,16, RedHat identifies another problem in 
Aaron's screen shot of #14.   That is the added text of "14e4|16a8" next to 
the adapters.  RH further explains that (the extra text) is already discovered 
in RH135418.
(unfortunately I cannot verify this fact without being able to view 135418).

So, my premise for maintaining this bug in the "reopened" status is that once 
135418 is fixed, the screen will lose the "14e4|16a8" text and will again 
return to the original problem.  i.e. the screen shot will still not have 
enough information to differentiate between network adapters when installing. 
Comment 15 IBM Bug Proxy 2005-03-27 12:41:49 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|greg_kelleher@us.ibm.com    |marksmit@us.ibm.com




------- Additional Comments From khoa@us.ibm.com  2005-03-27 12:34 EST -------
Aaron/Mark - do you still see this bug on RHEL3 U4 GA which was released
last December ?  If not, please close this bug report.  Thanks. 
Comment 16 IBM Bug Proxy 2005-06-01 17:41:59 EDT
---- Additional Comments From marksmit@us.ibm.com  2005-06-01 17:38 EDT -------
This append is being added to 63 IBM/LTC bugzilla's. As of 6/1/2005 the bug 
submitter in this bug is no longer working in this area of IBM, testing of 
Linux distros.  Unfortunately, the bug submitter is not an edit-able field 
with LTCBugzilla.  The bug submitter will no longer be available for 
recreation attempts or patch testing.  Those requests will need to be made to 
the bug owner.
If the bug owner needs assistance with access to the machine, please contact 
via email/Sametime: dino@us.ibm.com .  I will be Dino's backup if he is un-
available:via email, SameTime or phone.

If the bug submitter disagrees with the above statements, I apologize if I 
made an error in the bug sort.  Please correct the appropriate bug by adding 
your own public (not internal) comment. 
Comment 17 IBM Bug Proxy 2005-06-14 13:39:36 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_DISTRO




------- Additional Comments From scheel@us.ibm.com  2005-06-14 13:36 EDT -------
Closing bug as Fixed by Red Hat per Red Hat's disposition and lack of activity
on IBM side. 
Comment 18 Red Hat Bugzilla 2006-02-21 13:59:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.