Bug 106723 - Anaconda error with custom partitioning
Anaconda error with custom partitioning
Status: CLOSED DUPLICATE of bug 106480
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 106727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 17:27 EDT by Jim Sibley
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Sibley 2003-10-09 17:27:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
Anaconda error while trying to format dasd



Version-Release number of selected component (if applicable):
Taroon-re1004.RC1.0-s390-as-disc1-ftp.iso

How reproducible:
Always

Steps to Reproduce:
1. VM ipl from reader
2.  ssh -X address
3. customer partioning
    

Actual Results:  Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 768, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/partitioning.py", line 53, in partitionObjectsInitialize
    partitions.setFromDisk(diskset)
  File "/usr/lib/anaconda/partitions.py", line 86, in setFromDisk
    diskset.refreshDevices()
  File "/usr/lib/anaconda/partedUtils.py", line 706, in refreshDevices
    self.openDevices(intf, initAll, zeroMbr, clearDevs)
  File "/usr/lib/anaconda/partedUtils.py", line 811, in openDevices
    rc = intf.messageWindow(_("Warning"),
AttributeError: 'NoneType' object has no attribute 'messageWindow'



Additional info:
Comment 1 Bill Nottingham 2003-10-09 17:52:16 EDT

*** This bug has been marked as a duplicate of 106480 ***
Comment 2 Bill Nottingham 2003-10-09 23:01:44 EDT
*** Bug 106727 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.