Bug 106733 - nautilus shows invalid filenames on smb shares
Summary: nautilus shows invalid filenames on smb shares
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2-extras   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-09 23:19 UTC by Mikko Paananen
Modified: 2013-04-02 04:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 20:27:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikko Paananen 2003-10-09 23:19:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030822
Mozilla Firebird/0.6.1

Description of problem:
Nautilus (gnome-vfs2-extras libsmb.so) seems to have problems with non-US-ASCII
filenames on smb-shares. When I browse to directory with such filenames, some
characters are shown as question marks and (invalid unicode) is shown after
filename.

Unfortunately, Nautilus has tendency to sometimes rename files as it sees fit,
especially after viewing file properties. This will left filenames broken and
add "(invalid unicode)" after the name.


Version-Release number of selected component (if applicable):
gnome-vfs2-extras-0.99.10-3.1

How reproducible:
Always

Steps to Reproduce:
1. Type a smb://server/home url into nautilus location field.
2. Type in username+password
3. View contest of directory


Actual Results:  Filenames with unicode characters are wrong:

Lukujärjestys-syksy-2003.txt
lääkbiokemia.doc

Are shown as:

Lukuj?rjestys-syksy-2003.txt (virheellistä Unicodea)
l??kbiokemia.doc (virheellistä Unicodea)

Also, I copied file "GruÃkarten von bine.jpg" to SharedDocs directory on my
laptop, it became "GruâÆkarten von bine.jpg" on windows. On that form it
shows right on name on nautilus, but nowhere else. After fixing filename it
shows again wrong on Nautilus.


Expected Results:  smbclient shows right names when share is accessed using
smbclient '\\server\home'.


Additional info:

Samba server is 3.0 (since that is first version that supports unicode filenames).

Filenames on server are UTF-8 encoded and show fine on Windows XP and W98 clients.

Other server (laptop) has W-XP sp1.

Comment 1 Alexander Larsson 2003-10-10 09:36:09 UTC
Hopefully this can be fixed in the new smb method implementation which uses
libsmb from samba 3. We need to do charset coversion in the smb method depending
on the charset on the smb server.

Comment 2 Mikko Paananen 2004-05-03 20:27:54 UTC
OK, this works fine in current Gnome 2.6.

Closing...



Note You need to log in before you can comment on or make changes to this bug.