Bug 106755 - recode support in php
recode support in php
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 05:26 EDT by JP Matos
Modified: 2009-02-05 07:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 07:28:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JP Matos 2003-10-10 05:26:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031003

Description of problem:
recode support in php is not included in RedHat or Fedora rpms. I routinely
rebuild such rpms without problems but it is hardly convenient and it seems a
very minor and trivial addition. Is there a reason?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A
    

Additional info:
Comment 1 Joe Orton 2003-10-13 10:39:38 EDT
I just tried enabling it, but httpd crashes on startup, librecode.so was using
the hash_insert from libmysqlclient.so not the hash_insert from librecode.so.

#0  0x00001f91 in ?? ()
#1  0x4013d6e0 in hash_insert () from /usr/lib/mysql/libmysqlclient.so.10
#2  0x4039aee8 in find_alias (outer=0x81a6d30, name=0x40452b31 "data",
find_type=135958168)
    at names.c:299
#3  0x4039cb0f in register_all_modules (outer=0x81a6d30) at outer.c:457
#4  0x4039d21c in recode_new_outer (auto_abort=false) at outer.c:550
#5  0x40215e91 in zm_startup_recode (type=1, module_number=11)
    at /usr/src/debug/php-4.3.3/ext/recode/recode.c:102
#6  0x402bdf3a in zend_startup_module (module=0x4032bf00)
    at /usr/src/debug/php-4.3.3/Zend/zend_API.c:1005
Comment 2 Tomas 2007-01-28 00:57:36 EST
Have you tried compiling recode as shared extension? Debian has been packaging
recode, imap and mysql extensions for ages.

If redhat and fedora does not include recode support in PHP, it stops possible
improvements in some PHP script packages (for example - SquirrelMail). PHP
recode extension provides character set conversion functions that are more
stable than functions provided by iconv extension.
Comment 3 Joe Orton 2007-01-29 08:14:41 EST
Using a shared extension this should now be feasible since RTLD_DEEPBIND was
enabled.
Comment 4 John Poelstra 2008-07-04 00:13:53 EDT
triaged
Comment 5 Joe Orton 2009-02-05 07:28:09 EST
Done for Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.