Bug 10677 - SCSI module won't accept documented options
SCSI module won't accept documented options
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-09 05:18 EDT by Peter Hunter
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-22 03:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Hunter 2000-04-09 05:18:12 EDT
Options for aic7xxx.o which worked perfectly well with 2.2.12-20 from

Redhat-6.1 no longer work:



alias scsi_hostadapter aic7xxx

options aic7xxx

aic7xxx='tag_info:{{16.16.16.16.16.16.16}.{16.16.16.16.16.16.16}}'



Causes root device to fail to be recognised, and therefore machine

would not boot. /usr/src/linux/drivers/scsi/README.aic7xxx still lists

this option as correct, as far as I can see.
Comment 1 Doug Ledford 2000-04-22 03:08:59 EDT
Those options still work fine in the aic7xxx module, I would suspect that your
kernel upgrade did not include making a new initrd image and as a result the
panic is coming from the fact that the aic7xxx module is never getting loaded
with the new kernel.
Comment 2 Peter Hunter 2000-05-05 16:33:59 EDT
No. That's not what happened. I know because I mounted the initrd file (which had

been made automatically by the installer when it upgraded from 6.1). When I did

so, if I ran the insmod listed in there, my SCSI cards would not be detected: the

insmod didn't give an error, I don't think, but it didn't detect the cards. When

I did the insmod without the module options, all was well (though of course I

don't get tagged command queueing.)
Comment 3 Doug Ledford 2000-05-09 23:54:59 EDT
I need to know the exact error messages when trying to load the aic7xxx driver
with options to be of any more help.  I'm not sure how you mounted the initrd
and loaded the driver if the machine panics when the module doesn't load
properly.  In any case, I need to know the particular commands used, the kernel
in use, the module you are trying to load, and the exact messages from both the
insmod command and the kernel after the load was attempted (which you can get by
using the dmesg command).

Note You need to log in before you can comment on or make changes to this bug.