Bug 106790 - Network interface startup/shutdown logic in apmscript is horribly broken.
Network interface startup/shutdown logic in apmscript is horribly broken.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 12:44 EDT by Anton Solovyev
Modified: 2014-03-16 22:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 17:57:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Solovyev 2003-10-10 12:44:58 EDT
1. Bringing up at the resume only those interfaces that were up at the last
suspend is wrong. For typical mobile user that makes it impossible to get
connected to ethernet if the laptop was waken up and suspended without ethernet
network.

Please return old Redhat 7 behavior when all interfaces are taken up and down on
suspend/resume.

2. The code that removes network interface modules at suspend is removed. That
makes it impossible to use Cisco Aironet cards.

Please return old Redhat 7 behavior when all interface modules are removed at
suspend.

Steps to reproduce -- Redhat 9 on IBM Thinkpad, Cisco Aironet card. Try to
suspend -resume, observe.

This is bad. Have you even tested this stuff??? It worked before and now it is
completely broken. What are you thinking about???
Comment 1 Bill Nottingham 2003-10-10 12:48:21 EDT
Removing the ethernet modules is *broken*; this leads to definite issues with
hotplug, among others. Moreover, it implies a kernel bug if you can't suspend
without unloading the modules.

Generally, the *entire* script needs rewritten from scratch.
Comment 2 Anton Solovyev 2003-10-10 13:41:30 EDT
> Removing the ethernet modules is *broken*; this leads to definite issues with
> hotplug, among others. Moreover, it implies a kernel bug if you can't suspend
> without unloading the modules

Ok. I can live with that. I tend to agree Cisco Aironet drivers (airo and
airo_cs) are broken. I have verified that after a suspend the modules become
unusable. The unloading here is just a workaround.

The second part though is still valid. I suspend the laptop at work and go home.
At home I use wireless and suspend and wake it up a few times. At this point
wired ethernet is obviosly down. I come back to work and the wired ethernet is
not brough up since it was down at the last suspend. It would hurt nothing if
all interfaces were taken up and down each time.

I appreciate timely answer. I also would like to let you know that this (Redhat
on laptops) is really important to us here. So, please keep working on it. Thanks!
Comment 3 Bill Nottingham 2005-02-02 17:57:37 EST
For handling hotplug interfaces and interface changes, something like
NetworkManager is the best solution; I don't think apmscript will be
extended in this manner.

Note You need to log in before you can comment on or make changes to this bug.