Bug 106803 - symbols missing: get_user_size and put_user_size
symbols missing: get_user_size and put_user_size
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 15:00 EDT by Kristofer Spinka
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-10 15:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kristofer Spinka 2003-10-10 15:00:20 EDT
Description of problem:
  In mm/usercopy.c, get_user_size and put_user_size are in fact exported, 
however the kernel image that shipped with RC1 does not show these symbols in 
either /boot/System.map or /proc/ksyms and modules attempting to resolve them 
cannot.

  /kristofer

Version-Release number of selected component (if applicable):
kernel-2.4.21-3.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. grep get_user_size /proc/ksyms
2. grep put_user_size /proc/ksyms
Comment 1 Arjan van de Ven 2003-10-10 15:05:22 EDT
these functions only exist in the hugemem kernel, not other kernels, and
consequently, the functions are only exported from this kernel and not others.
Comment 2 Kristofer Spinka 2003-10-10 15:13:44 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.