Bug 106807 - LTC4885-Possible bug in GTK and miniChinput integration
LTC4885-Possible bug in GTK and miniChinput integration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: miniChinput (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 15:26 EDT by IBM Bug Proxy
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 05:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-10-10 15:26:48 EDT
The following has be reported by IBM LTC:  
Possible bug in GTK and miniChinput integration
Hardware Environment:
IBM/IntelliStation Z Pro
Dual-processors Intel Xeon 

Software Environment:
RedHat 9.0 / Simplified Chinese locale (GB18030)
Gtk 2.2.1 (original from RH)
miniChinput, chinese input method, several versions were tested.

Steps to Reproduce:
1. Run a gtk example with two entry widgets
2. Switch focus, using the mouse, to a second widget while holding a key down 
in the first
3. Without releasing key, keep switch the focus between the widgets

Actual Results:
To be able to enter characteres on both widgets

Expected Results:
Keyboard stops responding properly

Additional Information:
This pretty much cause eclipse to stop working on Linux/zn_CH environments.
See eclipse bug: 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=43009
I'm also submited a bug against GTK, it has more detailed steps and info, it 
also contains an example testcase:
http://bugzilla.gnome.org/show_bug.cgi?id=123580Glen / Greg
Please open Redhat problem.  Thanks
Comment 1 Owen Taylor 2003-10-15 14:29:33 EDT
Pretty much positive this is a miniChinput bug; I put some debug statements
in and what GTK+ is sending to the input method looks fine.

And once you get miniChinput in the stuck state, the problem exists for
other processes as well ... even if GTK+ was buggy, it shouldn't be
able to cause such a problem.

(Just because it doesn't happen with other apps doesn't mean it isn't
a miniChinput bug ... GTK+ uses different parts of the XIM protocol
than many other apps.)
Comment 2 Yu Shao 2003-10-20 21:10:23 EDT
It seems a bug in XIM key event synchronization part, key events are cached not
getting thru. Using Dynamic Event flow model in IM server itself will fix the
problem.

The new package is here: http://people.redhat.com/yshao/miniChinput/
or Red Hat Rawhide.

miniChinput-0.0.3-52.i386.rpm 
Comment 3 IBM Bug Proxy 2003-10-31 12:15:47 EST
------ Additional Comments From felipe_heidrich@ca.ibm.com  2003-31-10 12:11 -------
does the status FIXEDAWAITINGTEST mean that the Submitter has to verify (test) 
the fix ? 
Comment 4 mark wisner 2003-11-26 06:01:42 EST
------ Additional Comments From khoa@us.ibm.com  2003-25-11 22:27 -------
Yes, the bug submitter needs to verify the fix.  Thanks. 
Comment 5 mark wisner 2003-11-26 11:36:02 EST
------ Additional Comments From felipe_heidrich@ca.ibm.com  2003-26-11 11:32 -------
I verify that the original bug report in here is fixed.

But I can't say miniChinput is working 100% with Eclipse, it's not hard to get 
in situations where it stops working but I don't have a concrete test cases to 
reproduce the problem. 
Comment 6 Owen Taylor 2003-11-26 11:56:38 EST
I tracked this down to Xlib bugs. Unfortunately, I haven't had
time to get write that up and propose fixes. I'll try to do that
soon.
Comment 7 Felipe Heidrich 2004-04-21 17:15:15 EDT
Look at this pr:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=57408
My last comment has steps how to cause a failure situation.
Comment 8 Felipe Heidrich 2004-04-22 15:23:28 EDT
I've tested this with GTK 2.4 and the latest miniChinput (from 
fedora: 0.0.3-53) and bug still happens.
You just need to open the IM in a textentry and tab to a second 
textentry. This causes the input method to stop working.
This is critical IMO.
Comment 9 IBM Bug Proxy 2004-04-22 15:41:47 EDT
----- Additional Comments From felipe_heidrich@ca.ibm.com  2004-04-22 15:42 -------
See bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=57408#c7
For new steps on how to reproduce the bug. 
Comment 10 Yu Shao 2004-05-16 21:17:57 EDT
Sorry for the late reply, could anyone have a look of
miniChinput-0.0.3-56 which has just been built, it should fix the
problem, thanks.
Comment 11 Felipe Heidrich 2004-05-17 11:09:55 EDT
Where is miniChinput-0.0.3-56 available for download ?
Comment 12 Yu Shao 2004-05-18 03:12:40 EDT
Sorry, you can download from here
http://people.redhat.com/yshao/miniChinput/

Or you can download it from Red Hat Rawhide which is available from
many mirror sites.
Comment 13 Lawrence Lim 2004-09-10 07:23:38 EDT
Hi Felipe,
Does the miniChinput-0.0.3-56 works for you? 


Cheers,
Lawrence

Comment 14 IBM Bug Proxy 2004-09-10 12:16:08 EDT
----- Additional Comments From felipe_heidrich@ca.ibm.com  2004-09-10 12:13 -------
Well, it does fix this one bug I mentioned. But miniChinput is far from been 
stable, yesterday I was testing Eclipse 3.0.1 RC2 on Chinese and I had to 
restart minichinput several times... 
Comment 15 Lawrence Lim 2004-09-12 23:42:45 EDT
We are now in the transition phase to move away from Input Method such
as miniChinput which utilise the legacy X Input Method (XIM)
architecture. You may like to try out the new Simplified Chinese Input
Method by downloading the im-sdk and iiimf-le-chinput packages from
the Red Hat Rawhide. There is also a later version of miniChinput now
available: miniChinput-0.0.3-58.

Hope this help.



Comment 16 Lawrence Lim 2004-09-29 05:02:35 EDT
Resolving this bug for now. Please reopen this bug if the problem for
miniChinput still persist. 

For bugs related to iiimf-le-chinput, please file a New bug if it is
not reported.


Thanks.
Comment 17 IBM Bug Proxy 2005-07-11 18:22:30 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|TESTED                      |ACCEPTED
          QAContact|khoa@us.ibm.com             |mranweil@us.ibm.com




------- Additional Comments From mranweil@us.ibm.com  2005-07-11 18:16 EDT -------
Will close this based on comment #15 that it fixes the bug this was opened for. 

Note You need to log in before you can comment on or make changes to this bug.