This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 106823 - kbackgammon gives sig11
kbackgammon gives sig11
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdegames (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 18:47 EDT by Damian Menscher
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 08:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Damian Menscher 2003-10-10 18:47:20 EDT
Description of problem:
I'm using the gnome window manager, in case that's relevant.

kbackgammon starts just fine, and I select new game.  Grabbing a piece with the 
mouse to move it causes a sig11.

Version-Release number of selected component (if applicable):
kdegames-3.1-4

How reproducible:
Always

Steps to Reproduce:
0. run gnome (don't know if this is relevant)
1. run kbackgammon
2. try to move a piece
    

Additional info:

Here's info from the backtrace, in case it's helpful:

#0  0xffffe002 in ?? ()
#1  0x4075d57d in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x0806624b in QFrame::paintEvent(QPaintEvent*) ()
#4  0x08144e50 in ?? ()
#5  0x080607f9 in QFrame::paintEvent(QPaintEvent*) ()
#6  0x40af4040 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#7  0x0807fdbc in KBgEngine::staticMetaObject() ()
#8  0x0807a276 in KBgEngineOffline::staticMetaObject() ()
#9  0x0807797f in KBgEngineOffline::staticMetaObject() ()
#10 0x40af40c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#11 0x0806671d in QFrame::paintEvent(QPaintEvent*) ()
#12 0x0806bf45 in QFrame::paintEvent(QPaintEvent*) ()
#13 0x0806ea17 in QFrame::paintEvent(QPaintEvent*) ()
#14 0x40b2800c in QWidget::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x40a95f24 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#16 0x40a95753 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#17 0x406f11e9 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#18 0x40a3c198 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#19 0x40a39cdf in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#20 0x40a4ebda in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#21 0x40aa9cf6 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#22 0x40aa9b98 in QEventLoop::exec() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#23 0x40a96151 in QApplication::exec() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#24 0x08060498 in QFrame::paintEvent(QPaintEvent*) ()
#25 0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Ngo Than 2003-10-13 08:29:36 EDT
Does it crash if you start it in KDE desktop instead GNOME?

I cannot reproduce with KDE 3.1.4 if i start it in KDE Desktop.

Please reopen it again if this bug is not fixed.

Note You need to log in before you can comment on or make changes to this bug.