Bug 106851 - Upgrading RH 8.0 Installation to FC/0.94 failes with anaconda crash
Summary: Upgrading RH 8.0 Installation to FC/0.94 failes with anaconda crash
Status: CLOSED DUPLICATE of bug 105811
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-12 00:05 UTC by Kai 'wusel' Siering
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda's crash dump (568.69 KB, text/plain)
2003-10-12 00:07 UTC, Kai 'wusel' Siering
no flags Details

Description Kai 'wusel' Siering 2003-10-12 00:05:04 UTC
Description of problem:

Upgrading a RH 8.0 Installation fails:

 - Graphical update terminates after crash of X-Server
 - Text-based update fails with "unhandled exception" within anaconda
   (anacdump.txt has been saved and will be added to this report)

Version-Release number of selected component (if applicable):

Dunno; anaconda from the FC/0.94 images found on ftp.redhat.com.

How reproducible:

Boot from first CD. Boot "linux text", since graphic mode does not
work for some reason. Select updating /dev/hda2, which holds the
RedHat 8.0 installation.

Wait.

After checking the installed packages from RH 8.0, anaconda terminates
with:

    Traceback (most recent call last):
      File "/usr/bin/anaconda", line 1106, in ?
        intf.run(id, dispatch, configFileData)
      File "/usr/lib/anaconda/text.py", line 451, in run
        rc = apply(win, (self.screen, ) + args)
    TypeError: __call__() takes exactly 2 arguments (4 given)
    [...]

Steps to Reproduce:
1. Boot "linux text" on K7S5 Mainboard with Duron 900, MGA G400 AGP
2. Try to upgrade existing RH 8.0 installation
3. Anaconda fails
    
Actual results:

Upgrading from RH 8.0 to FC .94 is not possible. 

Expected results:

A nicely updated system.

Additional info:

Comment 1 Kai 'wusel' Siering 2003-10-12 00:07:02 UTC
Created attachment 95119 [details]
Anaconda's crash dump

Comment 2 Jeremy Katz 2003-10-13 22:34:58 UTC

*** This bug has been marked as a duplicate of 105811 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.