Bug 106892 - dhcp client is not picking up timezone from dhcp-server option 2
dhcp client is not picking up timezone from dhcp-server option 2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 00:15 EDT by Don Russell
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-13 15:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2003-10-13 00:15:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031008

Description of problem:
When it came to the screen about date/time, the ntp server address was properly
displayed. I presume it determined that from the dhcp server - dhcp option 42.

That's GREAT!

But, it did not pick up the timezone information from dhcp option 2.

The time displayed was incorrect because it incorrectly assumed the hardware
clock was set to UTC.

This resulted in several files having a "future date/time stamp"...

Since dhcp told the system the ntp server address (dhcp option 42) and the UTC
offset (dhcp option 2) Fedora should synch to the specified ntp server. (The
time synch should be done as close to network startup as possible to that any
files that get modified have the correct timestamp.

Choosing "hardware clock uses UTC" should only change the hardware clock, not
the displayed time nor the time used to timestamp files.

Version-Release number of selected component (if applicable):
firstboot-1.2.1-1

How reproducible:
Didn't try


Additional info:
Comment 1 Nils Philippsen 2005-07-07 06:28:03 EDT
The NTP server was set from the dhclient scripts, the timezone should probably
be set from there as well. Changing component, marking as enhancement.
Comment 2 Jason Vas Dias 2005-10-13 15:53:30 EDT
This bug is fixed in Rawhide (dhcp-3.0.3-7+) and FC-4 (dhcp-3.0.2-22+) .
IF you supply the option 
   DHCP_TIME_OFFSET_SETS_TIMEZONE=yes
in /etc/sysconfig/network or in a /etc/sysconfig/network-scripts/ifcfg-eth* 
script, THEN the dhclient script WILL make /etc/localtime a copy of the 
/usr/share/zoneinfo/Etc/GMT{-,+}$offset file. 
ie. if your dhcp server gives a client a time-offset option of -18000 (EDT),
then dhclient-script sets the timezone to 'GMT+5' (+-ve hours west of GMT).
The dhcp server must take account of DST changes in the time-offset value
it supplies to clients, since the GMT* zones have no DST info.

Note You need to log in before you can comment on or make changes to this bug.