Bug 106914 - kdegames requires arts-devel
kdegames requires arts-devel
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdegames (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 10:17 EDT by Matthew Leingang
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-14 07:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Leingang 2003-10-13 10:17:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I was trying to play kolf, a game in the kdegames package, but was not getting
any sound.  Moreover, the game was hanging for several seconds each time the
ball struck a wall.

The error messages were all "cannot connect to server:
unix:/tmp/mcop-[username]/[host]-[id]..."  Googling this error message led me to
believe it was an arts problem.



Version-Release number of selected component (if applicable):
kdegames-3.1-4

How reproducible:
Always

Steps to Reproduce:
1. # rpm -e arts-devel; killall artsd
2. $ /usr/bin/kolf
3. start a game and putt the ball around
    

Actual Results:  mcop warning: user defined signal handler found for SIG_PIPE,
overriding
mcop warning: user defined signal handler found for SIG_PIPE, overriding
ASSERT: "id < (int)d->m_list.count()" in kaction.cpp (1539)
unix_connect: can't connect to server
(unix:/tmp/mcop-leingang/spade_fas_harvard_edu-6a37-3f8ab292)
unix_connect: can't connect to server
(unix:/tmp/mcop-leingang/spade_fas_harvard_edu-6a3b-3f8ab293)


Expected Results:  Sound!

Additional info:

Turns out all I had to do was install the arts-devel package from the same
RedHat 9 distro.  I didn't install this package at the outset because I hadn't
thought I would need it.  Once I did, kolf makes sounds happily and the lags are
gone.

It seems to me that arts-devel should be a prerequisite for the kdegames package
if it's needed to make at least one of the games function properly.  Simply
making that prereq would make this bug go away.
Comment 1 Ngo Than 2003-10-14 07:44:10 EDT
it's a bug in arts rpm, which is already fixed in KDE 3.1.4 or in rawhide. You
could download KDE 3.1.4 for RHL 9 from ftp.kde.org. thanks for your report

Note You need to log in before you can comment on or make changes to this bug.