Bug 106950 - /etc/profile sourced in non interactive logins.
/etc/profile sourced in non interactive logins.
Status: CLOSED DUPLICATE of bug 65509
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 17:46 EDT by Steve Traylen
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Traylen 2003-10-13 17:46:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030821

Description of problem:

The file 

/etc/zshenv

contains

source /etc/profile

which has the undesirable effect that all shells, interactive, login
or anything source the /etc/profile which is clearly undesirable.

Version-Release number of selected component (if applicable):
zsh-4.0.4-5

How reproducible:
Always

Steps to Reproduce:
1.Log in as normall
2.Type zsh 
3.
    

Additional info:
Comment 1 Jens Petersen 2003-11-25 03:01:05 EST

*** This bug has been marked as a duplicate of 65509 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.