Bug 10698 - core dump starting mc from root account
core dump starting mc from root account
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-10 10:32 EDT by Andrea Sterbini
Modified: 2013-04-02 00:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 08:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace and ltrace of mc runs (both as root and as user) (222.91 KB, application/octet-stream)
2000-04-14 10:39 EDT, Andrea Sterbini
no flags Details

  None (edit)
Description Andrea Sterbini 2000-04-10 10:32:15 EDT
My system is a RedHat 6.2 on a AMD K7.
When I use mc as a user it works fine.
When I start mc from the root account it says:


[root@sterbini /root]# mc

GLib-CRITICAL **: file gstrfuncs.c: line 993 (g_strcasecmp): assertion `s1
!= NULL' failed.

           GLib-CRITICAL **: file gstrfuncs.c: line 993 (g_strcasecmp):
assertion `s1 != NULL' failed.
                      Segmentation fault (core dumped)

Below I enclose the output of "gdb mc core"

[root@sterbini /root]# gdb /usr/bin/mc core
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `/usr/bin/mc -P'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libgpm.so.1...(no debugging symbols found)...
done.
Reading symbols from /usr/lib/libglib-1.2.so.0...
(no debugging symbols found)...done.
Reading symbols from /lib/libext2fs.so.2...(no debugging symbols
found)...done.
Reading symbols from /lib/libcom_err.so.2...(no debugging symbols found)...
done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /usr/lib/libncurses.so.4...done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /lib/libnss_files.so.2...done.
Reading symbols from /lib/libnss_nisplus.so.2...done.
Reading symbols from /lib/libnsl.so.1...done.
Reading symbols from /lib/libnss_nis.so.2...done.
#0  0x805cd2c in strcpy () at ../sysdeps/generic/strcpy.c:30
30      ../sysdeps/generic/strcpy.c: No such file or directory.
(gdb) where
#0  0x805cd2c in strcpy () at ../sysdeps/generic/strcpy.c:30
#1  0x80df4e0 in _gpm_buf ()
#2  0x8065021 in strcpy () at ../sysdeps/generic/strcpy.c:30
#3  0x808416e in getch ()
#4  0x400739cb in __libc_start_main (main=0x8083ff0 <getch+27712>, argc=2,
    argv=0xbffffae4, init=0x804a888 <_init>, fini=0x80b7a1c <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffadc)
    at ../sysdeps/generic/libc-start.c:92
(gdb)

Ciao
Andrea Sterbini
Comment 1 Andrea Sterbini 2000-04-10 10:33:59 EDT
I had the same problem also in RedHat 6.1
Comment 2 Andrea Sterbini 2000-04-11 06:17:59 EDT
On my other PC (AMD K6/200 + RedHat 6.2) the problem does'nt happen.
Comment 3 Andrea Sterbini 2000-04-14 10:39:59 EDT
Created attachment 201 [details]
strace and ltrace of mc runs (both as root and as user)
Comment 4 Jonathan Blandford 2000-07-19 13:11:15 EDT
I am unable to reproduce this at all, and cannot glean any insight from
the backtrace.  Can you try a newer package and tell me if it still happens.
Comment 5 Andrea Sterbini 2000-08-02 08:21:32 EDT
I have tried mc-4.5.51 both from helix and Mandrake ... same problem.
I have not yet tried the rawhide version ... too many things to upgrade, sorry
Comment 6 Andrea Sterbini 2000-09-15 20:25:09 EDT
I have reinstalled a RedHat 6.2 from scratch on a new disk.
Now mc works on my K7 also when I am root.

Note You need to log in before you can comment on or make changes to this bug.