Bug 107035 - ps files get clipped by gv when viewed in landscape
ps files get clipped by gv when viewed in landscape
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gv (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
David Lawrence
http://www.dcs.kcl.ac.uk/staff/raph/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 11:16 EDT by Raphael Clifford
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version: 3.6.1-4.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 14:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Clifford 2003-10-14 11:16:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
I am using gv 3.5.8 in redhat 9 and am trying to view a postscript file. When I
view it in portrait it is fine but if I view it in landscape it is clipped so
that a third of the page on the right is missing.
The cause of this appears to be that gv simple rotates the page while
keeping the "frame" the same. So you are looking at a landscape document
through a portrait frame.  This is very frustrating as many ps documents come
like this (that is, not defined as landscape in the postscript but landscape
nonetheless) and so it is a very common problem, at least for me.  

Here is an example file
http://www.dcs.kcl.ac.uk/staff/raph/test.ps

Here is a screenshot of page 3, for example.

http://www.dcs.kcl.ac.uk/staff/raph/clipped.png

Any help would be very much appreciated.  It seems that a "rotate page" feature
might be all that is needed.

Raphael
P.S. I have tried ghostscript 7.05 from redhat 9 and 7.07 from rawhide as well
with no difference.


Version-Release number of selected component (if applicable):
gv 3.5.8, gs 7.05

How reproducible:
Always

Steps to Reproduce:
1. get postscript file above
2. view in gv and select landscape mode
3. observe the right hand side of the pages. Page 3 shows it well
    

Actual Results:  The right hand third (roughly) is missing completely in
landscape mode

Expected Results:  To be able to see the whole page in landscape mode in the
same way that it can be seen in portrait mode.

Additional info:

The exact same effect occurs when using ggv in redhat 9.
Comment 1 Orion Poplawski 2005-12-15 17:14:33 EST
Please test with gv-3.6.1-4.fc4 from Fedora Extras
Comment 2 Raphael Clifford 2005-12-29 07:31:01 EST
Sadly both those links are now down and I don't have a fedora system to play
with.  Without wanting to sound complaining ( :) ) the time lag was over two
years for the first reply to this bug report!

Raphael


Note You need to log in before you can comment on or make changes to this bug.