Bug 107057 - tuxstat seg faults on run.
tuxstat seg faults on run.
Status: CLOSED DUPLICATE of bug 104044
Product: Red Hat Linux
Classification: Retired
Component: tux (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 13:47 EDT by Mike Zimmerman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 17:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Zimmerman 2003-10-14 13:47:01 EDT
Description of problem:

Segmentation fault when using tuxstat.

Version-Release number of selected component (if applicable):

tux-2.2.9-1

How reproducible:

Run tuxstat.

Steps to Reproduce:
1. Run tuxstat.

    
Actual results:

Segmentation Fault

Expected results:

Information about running tux threads

Additional info:

Random information. I don't know if this comes back as useful or not, since
I'm not a programmer.

Strace:

execve("/usr/sbin/tuxstat", ["/usr/sbin/tuxstat"], [/* 24 vars */]) = 0
uname({sys="Linux", node="strongbad", ...}) = 0
brk(0)                                  = 0x8049f4c
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 
0x40016000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=26968, ...}) = 0
old_mmap(NULL, 26968, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40017000
close(3)                                = 0
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220W\1"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1536292, ...}) = 0
old_mmap(0x42000000, 1261416, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 
0x42000000
old_mmap(0x4212f000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3, 
0x12f000) = 0x4212f000
old_mmap(0x42132000, 8040, PROT_READ|PROT_WRITE, 
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x42132000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 
0x4001e000
set_thread_area({entry_number:-1 -> 6, base_addr:0x4001e280, limit:1048575, 
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, 
seg_not_present:0, useable:1}) = 0
munmap(0x40017000, 26968)               = 0
open("/proc/net/tux/stat", O_RDONLY)    = 3
read(3, "0 c9466800 0 ........ ........ ."..., 1024) = 1024
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

gdb:

GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols 
found)...
(gdb) run
Starting program: /usr/sbin/tuxstat 
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x4207a6db in strlen () from /lib/tls/libc.so.6
(gdb) where
#0  0x4207a6db in strlen () from /lib/tls/libc.so.6
#1  0x42071016 in _IO_str_init_static_internal () from /lib/tls/libc.so.6
#2  0x420646b7 in vsscanf () from /lib/tls/libc.so.6
#3  0x4206052d in sscanf () from /lib/tls/libc.so.6
#4  0x08048682 in read ()
#5  0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Ingo Molnar 2005-09-15 17:41:07 EDT

*** This bug has been marked as a duplicate of 104044 ***

Note You need to log in before you can comment on or make changes to this bug.