Bug 107058 - The boot.iso is named -T
Summary: The boot.iso is named -T
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-14 17:52 UTC by Forrest
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: FC2 test1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 21:15:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to give boot.iso a meaningful name (746 bytes, patch)
2003-10-14 17:54 UTC, Forrest
no flags Details | Diff
Patch to use only double quotes for $PRODUCTSTR (1.36 KB, patch)
2003-11-05 20:57 UTC, Forrest
no flags Details | Diff

Description Forrest 2003-10-14 17:52:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
I had forgotten about this until I just tried to copy over the boot.iso to my
burner, and noticed that the name was -T.  When creating the boot.iso, the -V is
used immediately followed by -T.  -V should be followed by the volume name or label.

Version-Release number of selected component (if applicable):
anaconda-runtime-9.0.95-1


How reproducible:
Always

Steps to Reproduce:
1.  Create a boot.iso using mk-images.i386 or take a look at the prebuilt one in
the images/ directory.


Expected Results:  boot.iso should have a name other than -T

Comment 1 Forrest 2003-10-14 17:54:24 UTC
Created attachment 95169 [details]
Patch to give boot.iso a meaningful name

Comment 2 Jeremy Katz 2003-10-14 18:58:48 UTC
Did something similar (but used $PRODUCT so that it's not hard-coded)

Comment 3 Forrest 2003-11-05 20:55:45 UTC
This worked to a point.  It now says PRODUCTSTR instead of -T ;o)

Comment 4 Forrest 2003-11-05 20:57:25 UTC
Created attachment 95741 [details]
Patch to use only double quotes for $PRODUCTSTR

Comment 5 Jeremy Katz 2003-11-06 16:32:52 UTC
Thanks, applied.  As might be obvious by now, the not having a runroot
case doesn't really get tested by me very often 

Comment 6 Forrest 2004-02-20 21:14:37 UTC
Yes, it is obvious you only use runroot ;o)

This works for me on FC2 test1, so I'll close it.  Be prepared for an
onslaught of other anaconda bugs I'll be filing later...


Note You need to log in before you can comment on or make changes to this bug.