Bug 107070 - OpenOffice.org 1.1 i18n support
Summary: OpenOffice.org 1.1 i18n support
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
: 107556 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-14 19:20 UTC by François Kooman
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-31 15:30:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description François Kooman 2003-10-14 19:20:49 UTC
Description of problem:

OpenOffice 1.1 only has a English and Italian dictionaries and no other UI
languages?

Version-Release number of selected component (if applicable):
openoffice.org-i18n-1.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core test3
2. Login as user with other language

    
Actual results:
OOo user interface still English

Expected results:
OOo user in native language

Additional info:
I've tested with Dutch, maybe other languages work?

Comment 1 Miloslav Trmac 2003-10-16 16:40:49 UTC
Czech doesn't work either.

Comment 2 Thorsten Tasch 2003-10-17 11:11:38 UTC
German is also missing.

Comment 3 Dan Williams 2003-10-20 16:22:43 UTC
*** Bug 107556 has been marked as a duplicate of this bug. ***

Comment 4 Zu 2003-10-21 04:51:58 UTC
Chinese language UI doesn't work also.

Comment 5 Dirk Schlüter 2003-10-22 07:14:03 UTC
German language only during setup. Setting 'german' in OO Options doesn't work.
Only english.

Comment 6 Dan Williams 2003-10-22 13:24:18 UTC
Working on this, shall be in 1.1.0-3.

Comment 7 Dan Williams 2003-10-22 13:29:05 UTC
There are actually 3 i18n problems:

1) UI Language
2) Dictionaries, Hyphenators, and Thesauruses
3) Correct UI Font for languages

Well, I've fixed (1), (2) means a load of dictionaries and won't be fixed in
1.1.0-3 but its a priority for 1.1.0-4.  (3) is a beast, since we can't just use
the system font (Tools->Options->Accessibility->Use System Font), which is
simply "Sans", which itself is a fontconfig "meta" font which OOo knows nothing
about.  So we get to special-case a bunch of langauges.... Sigh.

Comment 8 David Juran 2003-10-31 14:36:09 UTC
I guess you've noticed, 1.1.0-4 is here, but still no dictionaries )-:

Comment 9 Dan Williams 2003-10-31 15:26:59 UTC
Yes, no dictionaries for the moment.  Its not hard, just a lot of
redundant work (plus need to make sure we can redistribute them).  I
will file an additional bug for the dictionaries, but this bug is now
fixed.

Comment 10 Dan Williams 2003-10-31 15:30:35 UTC
Dictionaries/hyph/thes issue # is 108720.  This one now closed.


Note You need to log in before you can comment on or make changes to this bug.