Bug 107072 - Evolution hangs after being left open
Evolution hangs after being left open
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 15:47 EDT by Randy Eckenrode
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-20 13:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Eckenrode 2003-10-14 15:47:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009
Epiphany/1.0.1

Description of problem:
Whenever I leave Evolution open for a long period of time (i.e., more than
several hours), it tends to stop responding. When this happens, I am able to
kill all processes related to Evolution and restart.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open Evolution and leave it alone
2. ???
3. Evolution stops responding
The only constant is that it has stopped responding every time I left it open.

Actual Results:  Evolution stopped responding, and I had to kill it.

Expected Results:  I can read my mail and check my schedule without having to
kill Evolution and restart it.

Additional info:

I checked ~/.xsession-errors, and there was nothing about Evolution other than a
complaint regarding my Drafts folder, which I attached just in case it might be
relevent.

(evolution:5674): camel-WARNING **: Invalid root:
'//home/kenada/evolution/local/Drafts/mbox.ibex.index'
 
(evolution:5674): camel-WARNING **: version: TEXT.000 (TEXT.000)
 
(evolution:5674): camel-WARNING **: block size: 1024 (1024) OK
 
(evolution:5674): camel-WARNING **: free: 0 (0 add size < 1024) OK
 
(evolution:5674): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD
 
(evolution:5674): camel-WARNING **: flags: unSYNC
Comment 1 Jeremy Katz 2003-10-14 15:50:17 EDT
What is the process state of the evolution processes (in ps)?  Can you attach to
evolution with gdb and get a backtrace?
Comment 2 Randy Eckenrode 2003-10-14 18:14:24 EDT
According to PS, all three processes are sleeping (S). I attached to them with
GDB and got the following backtraces:

evolution
#0  0x004cbc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005cb066 in __lll_mutex_lock_wait () from /lib/tls/libc.so.6
#2  0x00618140 in __after_morecore_hook () from /lib/tls/libc.so.6
#3  0x006177d8 in __DTOR_END__ () from /lib/tls/libc.so.6
#4  0x00618140 in __after_morecore_hook () from /lib/tls/libc.so.6
#5  0x005563dc in _L_mutex_lock_9950 () from /lib/tls/libc.so.6
#6  0x091bab70 in ?? ()
#7  0x006177d8 in __DTOR_END__ () from /lib/tls/libc.so.6
#8  0x00619040 in fork_handler_pool () from /lib/tls/libc.so.6
#9  0x00619040 in fork_handler_pool () from /lib/tls/libc.so.6
#10 0xbfe817e8 in ?? ()
#11 0x00589912 in fork () from /lib/tls/libc.so.6
Previous frame identical to this frame (corrupt stack?)

evolution-wombat
#0  0x004cbc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005b4b2e in poll () from /lib/tls/libc.so.6
#2  0x007a1e46 in g_main_loop_get_context () from /usr/lib/libglib-2.0.so.0
#3  0x007a1276 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#4  0x007a19cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0x003d5088 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#6  0x0805e15c in main ()

evolution-alarm-notify
#0  0x004cbc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x005b4b2e in poll () from /lib/tls/libc.so.6
#2  0x007a1e46 in g_main_loop_get_context () from /usr/lib/libglib-2.0.so.0
#3  0x007a1276 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#4  0x007a19cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0x003d5088 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#6  0x08057405 in main ()
Comment 3 Randy Eckenrode 2003-10-14 18:23:30 EDT
Package versions installed, which may (or may not) be helpful:
glibc-2.3.2-98
evolution-1.4.5-2
gtk2-2.2.4-3.1
glib2-2.2.3-1.1
libbonobo-2.4.0-1
Comment 4 Jeremy Katz 2003-10-14 18:42:17 EDT
What version of ORBit2?  Also, can you get a backtrace of all the threads
(thread apply all bt) from the main evolution process?
Comment 5 Randy Eckenrode 2003-10-14 18:50:26 EDT
ORBit2-2.8.1.90-1

I’ll get another backtrace with all the threads when it stops responding again
later tonight.
Comment 6 Randy Eckenrode 2003-10-20 13:36:50 EDT
Just as a follow up, I would like to note that I have yet to have Evolution hang
since I updated my router firmware to a version that no longer mangles
fragmented packets.
Comment 7 Jeremy Katz 2003-10-20 13:38:57 EDT
Okay, guessing it's somehow related to that (and the main cause previously was
probably also the ORBit2 deadlock that got fixed)

Note You need to log in before you can comment on or make changes to this bug.