Bug 10708 - less in xterm doesn't work
Summary: less in xterm doesn't work
Status: CLOSED DUPLICATE of bug 9443
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: less (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-10 21:03 UTC by Brian Highers
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-18 06:48:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Highers 2000-04-10 21:03:49 UTC
If i do a "less file" on xterm i get strange ANSI codes output, instead
of the proper output.
If i do "cat file | less" the output is correct.
Once on a big file i used <ctrl-C> before less finished to load the file
and the output seemed to be correct.
If i change the terminal to xterm-24, or vt100, or ansi i see the right
output.

--Tommaso

Comment 1 Anonymous 2000-04-12 15:28:59 UTC
This bug and bug 10397 are the same as bug 9443.

I observe in 6.2 and having defined TERM=vt100; export TERM, that less
<filename> only echoes the lines I added to /etc/bashrc and then displays END.

The command cat <filename> | less, however, does work.

Craig

Comment 2 Tommaso Schiavinotto 2000-04-18 06:48:59 UTC
Taking a RedHat 6.1 and upgrading only the 'less' package it works. The RH6.2
for which i reported the bug is a full installation.

Regarding the other comment less doesnt make you see only the lines you added,
but it lets you see old lines that passed on the xterm.

Comment 3 Bernhard Rosenkraenzer 2000-07-26 18:41:56 UTC

*** This bug has been marked as a duplicate of 9443 ***


Note You need to log in before you can comment on or make changes to this bug.