Bug 107113 - Switching external/internal/both output on ATI MACH64 does no longer work
Switching external/internal/both output on ATI MACH64 does no longer work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 02:44 EDT by Jan Iven
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 04:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Iven 2003-10-15 02:44:37 EDT
Description of problem:

On a laptop with a Mach64 chip, switching between internal/external/both video
outputs does not work (used to work under RH7 and RH8). Neither via the keyboard
function key nor an external utility (atitvout,
http://www.stud.uni-hamburg.de/users/lennart/projects/atitvout/
).

Both keyboard and "atitvout" do work on the virtual console, even with XFree86
running on a different console. "atitvout" claims to use ATI VBE calls (and the
keyboard probably uses BIOS calls as well, so perhaps this comes from XFree86
disabling such calls?

Version-Release number of selected component (if applicable):
$ rpm -q XFree86
XFree86-4.3.0-37

(--) ATI(0): ATI 3D Rage Mobility graphics controller detected.
(--) ATI(0): Chip type 4C52 "LR", version 4, foundry TSMC, class 0, revision x01.


How reproducible:
Always

Steps to Reproduce:
1. hitting <Fn>-F10 or running "atitvout l; atitvout c; atitvout lc"
    
Actual results:
Keyboard: Nothing happens.
$ sudo ./atitvout c
VBE call failed.

Expected results:
Keyboard: Display should cycle through the available outputs
atitvout: Display should go to the selected device, if attached.

Additional info:

RFE: it would be very nice if different screen resolutions could be specified
for internal/external, and if the XFree86 server would get a RANDR event on
switching, to make full use of the external display capabilities.
Comment 1 Mike A. Harris 2003-10-15 04:49:19 EDT
>On a laptop with a Mach64 chip, switching between internal/external/both video
>outputs does not work (used to work under RH7 and RH8). Neither via the keyboard
>function key nor an external utility (atitvout,
>http://www.stud.uni-hamburg.de/users/lennart/projects/atitvout/
>).

Neither method is supported.  The Mach64 driver is provided as-is, and we do
not support atitvout, GATOS, or any other software that doesn't come with
the distribution.  Please contact the atitvout authors if you have problems
while using their utility.

The functionality provided by special laptop keystrokes to switch between
screens is done by the BIOS itself.  XFree86 is not involved.  That is also
not supported.  If you believe this to be due to a bug in XFree86 or in the
XFree86 "ati" driver for Mach64, please report it to the XFree86 project
at http://bugs.xfree86.org so that the driver maintainer can investigate
the matter and determine a resolution.

Closing as NOTABUG as we do not support configurations which use software
we do not supply which interferes with the video hardware, and may conflict
with the running XFree86 server.

Note You need to log in before you can comment on or make changes to this bug.