Bug 107130 - nautilus crashes after startx when not drawing desktop
nautilus crashes after startx when not drawing desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 04:58 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 06:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of nautilus crash (bug budd) (9.58 KB, text/plain)
2003-10-15 06:57 EDT, Need Real Name
no flags Details
screenshot of nautilus crash announcement (61.03 KB, image/jpeg)
2003-10-15 07:09 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-10-15 04:58:09 EDT
Description of problem:
If nautilus is configured to not draw the desktop it crashes just after
the 'fedora core' banner finishes drawing the icons
The place on the panel where windows are minimized to is temporarily black

Version-Release number of selected component (if applicable):
nautilus-2.4.0-5

How reproducible:
Always

Steps to Reproduce:
1. System Tools -> More System Tools -> Configuration Editor -> apps -> nautilus
  -> preferences 
2. uncheck 'show_desktop'
3. restart X
    
Actual results:
nautilus crashes (this happens in fedora core test1, test2 and test3)


Expected results:
Should work without problems like in RH9


Additional info:
Comment 1 Alexander Larsson 2003-10-15 05:11:09 EDT
Hmm. It works for me, can you get a backtrace of the crash?
Comment 2 Need Real Name 2003-10-15 06:57:28 EDT
Created attachment 95199 [details]
backtrace of nautilus crash (bug budd)
Comment 3 Need Real Name 2003-10-15 07:09:46 EDT
Created attachment 95200 [details]
screenshot of nautilus crash announcement
Comment 4 Alexander Larsson 2003-10-15 08:14:28 EDT
Ugh, it seems to be something related to the trash directory. I wonder why I
can't reproduce it. Was this starting nauilus with show_desktop set to false, or
did you change it "live"?
Comment 5 Need Real Name 2003-10-15 08:35:37 EDT
Yes, this is starting nautilus with show_desktop set to false permanently!

It happens every time I boot and then do 'startx' (I do not use the gui boot)
(And I set show_desktop to false because I don't like icons on the desktop!)
Comment 6 Alexander Larsson 2003-10-15 09:46:30 EDT
Fixed in gnome-vfs2-2.4.1-1.
Comment 7 Need Real Name 2003-10-21 09:47:03 EDT
Gnome-vfs2-2.4.1-x indeed fixes the problem of nautilus crashing.

But another phenomenon that manifested itself at the same time as the
nautilus crash remains: when gnome is starting up a black bar
is temporarily drawn over the panel (in the location where windows
are minimized to).

I don't know if this bug is related or should be reported seperately.
Comment 8 Alexander Larsson 2003-10-22 06:00:51 EDT
Its not related, open a new bug.

Note You need to log in before you can comment on or make changes to this bug.