Bug 107137 - Nautilus crashes when trying to change permissions on large group of files
Nautilus crashes when trying to change permissions on large group of files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 07:52 EDT by Steven Harms
Modified: 2013-03-05 22:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 15:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing group of files I am trying to work on (23.44 KB, image/png)
2003-10-15 07:53 EDT, Steven Harms
no flags Details

  None (edit)
Description Steven Harms 2003-10-15 07:52:01 EDT
Description of problem:
Nautilus crashes when trying to change permissions on a large group of files

Version-Release number of selected component (if applicable):
Nautilus 2.4

How reproducible:
Select a whole bunch of files, try and change permissions

Steps to Reproduce:
1. Highlight alot of files
2. Right Click -> Properties -> Permissions
3. Click on any of the buttons
    
Actual results:
Nautilus slows to a halt, uses 100% cpu, then crashes

Expected results:
Permissions changed after I click ok

Additional info:

Debugging Information:
 
Backtrace was generated from '/usr/bin/nautilus'
 
(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -1085386624 (LWP 6648)]
[New Thread -1091871824 (LWP 9602)]
[New Thread -1091605584 (LWP 9601)]
[New Thread -1091339344 (LWP 9600)]
[New Thread -1091052624 (LWP 9599)]
[New Thread -1090786384 (LWP 9598)]
[New Thread -1090520144 (LWP 9597)]
[New Thread -1089045584 (LWP 7781)]
[New Thread -1088779344 (LWP 6653)]
[New Thread -1087779920 (LWP 6650)]
[New Thread -1087513680 (LWP 6649)]
 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x00b6dc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00b6dc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0012498b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x05c1c7f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0058e279 in g_type_check_instance_cast ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x080b10ef in fm_properties_window_get_type ()
#6  0x05d7dbb5 in nautilus_file_can_rename ()
   from /usr/lib/libnautilus-private.so.2
#7  0x05b18bb0 in _gnome_vfs_job_complete () from
/usr/lib/libgnomevfs-2.so.0
#8  0x05b19169 in _gnome_vfs_job_complete () from
/usr/lib/libgnomevfs-2.so.0
#9  0x00399b33 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
#10 0x00396fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
#11 0x00397fd8 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#12 0x003982ef in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#13 0x003989cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0x0087044f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x08c350b0 in ?? ()
#16 0xbff09328 in ?? ()
#17 0x080653a6 in nautilus_application_new ()
[mindwarp@genesis mindwarp]$ vi bug2
[mindwarp@genesis mindwarp]$ more bug
Debugging Information:
 
Backtrace was generated from '/usr/bin/nautilus'
 
(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -1085386624 (LWP 6648)]
[New Thread -1091871824 (LWP 9602)]
[New Thread -1091605584 (LWP 9601)]
[New Thread -1091339344 (LWP 9600)]
[New Thread -1091052624 (LWP 9599)]
[New Thread -1090786384 (LWP 9598)]
[New Thread -1090520144 (LWP 9597)]
[New Thread -1089045584 (LWP 7781)]
[New Thread -1088779344 (LWP 6653)]
[New Thread -1087779920 (LWP 6650)]
[New Thread -1087513680 (LWP 6649)]
 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x00b6dc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00b6dc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0012498b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x05c1c7f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0058e279 in g_type_check_instance_cast ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x080b10ef in fm_properties_window_get_type ()
#6  0x05d7dbb5 in nautilus_file_can_rename ()
   from /usr/lib/libnautilus-private.so.2
#7  0x05b18bb0 in _gnome_vfs_job_complete () from
/usr/lib/libgnomevfs-2.so.0
#8  0x05b19169 in _gnome_vfs_job_complete () from
/usr/lib/libgnomevfs-2.so.0
#9  0x00399b33 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
#10 0x00396fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
#11 0x00397fd8 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#12 0x003982ef in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#13 0x003989cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0x0087044f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x08c350b0 in ?? ()
#16 0xbff09328 in ?? ()
#17 0x080653a6 in nautilus_application_new ()
Comment 1 Steven Harms 2003-10-15 07:53:34 EDT
Created attachment 95203 [details]
Screenshot showing group of files I am trying to work on

This is the group of files I am trying to work on.  Average size is about 60mb,
totaling 8.2gb.  167 files total.  Seems like nautilus is trying to change the
permissions before I click ok, and then because there are so many files, timing
out?
Comment 2 Alexander Larsson 2003-10-15 08:17:40 EDT
Which exact nautilus version is this?
Comment 3 Steven Harms 2003-10-15 09:18:59 EDT
[mindwarp@genesis mindwarp]$ nautilus --version
Gnome nautilus 2.4.0

I am using a fresh install of Fedora 0.95
Comment 4 Alexander Larsson 2003-10-16 04:05:21 EDT
i'd like the exact rpm version (rpm -q nautilus), but i assume you have 2.4.0-5
since i think thats in 0.95. That means this isn't a dup of bug 105869. 
Comment 5 Dan 2003-10-23 22:04:46 EDT
this does this to me with normal sized directories. like empty, only few files.
right click on folder go down to properties then it kills nautilus.  It does
restart after being killed.
I don't know if I should file a seperate bug report or not.
version nautilus-2.4.0-5.
Actually was able to change the emblems on three folders before it started
crashing.  Now it crashes every time.
Comment 6 Alexander Larsson 2004-10-04 10:23:20 EDT
Does this happen with gnome 2.8.0 in fc3test3 or later? I know there
was some changes related to this.
Comment 7 Marius Andreiana 2005-08-19 15:00:56 EDT
Works for me in 2.10. Tried with 1800 files. Nautilus does use all processor for
~40 seconds, but the other applications work. After that all it's ok and files
are changed.

Note You need to log in before you can comment on or make changes to this bug.