Bug 107153 - Initscripts does not support iproute2 tables
Initscripts does not support iproute2 tables
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 10:56 EDT by Tomas Edwardsson
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 05:22:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Edwardsson 2003-10-15 10:56:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
initscripts does not handle iproute2 tables and source based routing.
I would like to see something in the internal initscripts instead of
implementing them through rc.local (which doesn't work if you use for instance
"service network restart"). What I am doing, just so you get a picture is the
following:

/sbin/ip rule add from 192.168.2.0/24 table Usr1
/sbin/ip ro add default via 192.168.254.1 dev eth0 table Usr1

Keep up the good work.
Comment 1 Tomas Edwardsson 2004-11-17 05:22:59 EST
I'm closing this bug since it is old and no-one seems to be doing
anything about it.
Comment 2 Tomas Edwardsson 2004-11-17 05:25:13 EST
I'm closing this bug since it is old and no-one seems to be doing
anything about it.

Note You need to log in before you can comment on or make changes to this bug.