Bug 107162 - RH4957-Installing RHEL3 using the IUCV Network device - The RAMDISK boot process does not recognise the iucv parameter, if we specify it in the parameter file as documented in the release-notes .
RH4957-Installing RHEL3 using the IUCV Network device - The RAMDISK boot proc...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
s390 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 110876 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 12:02 EDT by sireesha
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-16 12:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sireesha 2003-10-15 12:02:28 EDT
The following has be reported by IBM LTC:  
Installing RHEL3 using the IUCV Network device - The RAMDISK boot process does 
not recognise the iucv parameter, if we specify it in the parameter file as 
documented in the release-notes .
Actual Results:
when IUCV=TCPIP is given in the paramater file(this is as documented in the 
release notes) 

Below is a part of the console message during the RAMDISK boot process.

SIOCSIFADDR: No such device               
iucv0: unknown interface: No such device 
SIOCSIFMTU: No such device               
SIOCSIFDSTADDR: No such device           

Expected Results:
Below is a part of the console message during the RAMDISK boot process when 
iucv works.

iucv0: 'TCPIP'                           
NETIUCV driver Version: 1.21  initialized
iucv0: connected with remote side
Comment 1 Jeremy Katz 2003-10-15 12:58:14 EDT
Can you please provide the parm file you're using?
Comment 2 sireesha 2003-10-15 14:25:42 EDT
Parameter file used:

* * * Top of File * * *                                       
 root=/dev/ram0                                                
 DASD=E0C1                                                     
 IUCV=TCPIP                                                    
 NETTYPE=iucv IPADDR=9.12.20.98 HOSTNAME=vm1l2.pdl.pok.ibm.com 
 NETMASK=255.255.255.255 GATEWAY=9.12.20.95 MTU=1492           
 DNS=9.12.16.2 SEARCHDNS=pdl.pok.ibm.com NETWORK=9.12.20.0     
 * * * End of File * * *                                     
Comment 3 Jeremy Katz 2003-10-15 15:01:09 EDT
I think you also need REMIP=  -- if you add that, does it work?
Comment 4 sireesha 2003-10-15 16:25:59 EDT
Specifying REMIP also dosen't work - it gives the same problem.
If I specify IUCV=iucv=TCPIP in the parameter file - it works.
so probably the script is looking for "IUCV=iucv=TCPIP" instead of "IUCV=TCPIP".
Comment 7 Brock Organ 2003-10-20 14:40:59 EDT
confirmed the parameter behavior locally, "IUCV=iucv=TCPIP" instead of
"IUCV=TCPIP" avoids the "no such device errors" ...
Comment 8 Jeremy Katz 2003-10-29 14:19:25 EST
Changed so that linuxrc.s390 can handle either IUCV=iucv=TCPIP or
IUCV=TCPIP in the parm file.
Comment 9 Jeremy Katz 2003-11-25 10:13:38 EST
*** Bug 110876 has been marked as a duplicate of this bug. ***
Comment 10 Jay Turner 2004-01-16 12:16:35 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-344.html

Note You need to log in before you can comment on or make changes to this bug.