Bug 10719 - kernel-2.2.14-5.0.i686 instabel on PIII machine
kernel-2.2.14-5.0.i686 instabel on PIII machine
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 03:50 EDT by gerald
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-22 03:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerald 2000-04-11 03:50:27 EDT
I installed RH6.2 on a PIII machine. At first sight the machine seems to
work normal. But as soon as the hard drive is used heavily, the system
begins reacting at random (unpredictable segfaults, characters are added
to files at random places, rpm -V xxx produces random md5 changes, file
sytem corruption, ...). If I put the harddrive into DMA mode, problems
get less, but are still present.

Downgrading to a i585 kernel resolved the problem. There are no problems
with the i686 kernel on PII class machines.

Below is some additional sytem information (dmesg):


Linux version 2.2.14-5.0 (root@porky.devel.redhat.com) (gcc version
egcs-2.91.66
 19990314/Linux (egcs-1.1.2 release)) #1 Tue Mar 7 20:53:41 EST 2000
Detected 451057693 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 448.92 BogoMIPS
Memory: 64016k/66556k available (1084k kernel code, 416k reserved, 976k
data, 64
k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 65536 (order 6, 256k)
Page cache hash table entries: 16384 (order 4, 64k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium III (Katmai) stepping 02
Checking 386/387 coupling... OK, FPU using old IRQ 13 error reporting
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfd998
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: 00:38 [1106/0596]: Work around ISA DMA hangs (00)
Activating ISA DMA hang workarounds.
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 65536 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.9)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
hda: ST313640A, ATA DISK drive
hdc: DVS DVD-ROM DSR-520H 990120MP, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: ST313640A, 12969MB w/512kB Cache, CHS=1653/255/63
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :  1044.702 MB/sec
   p5_mmx    :  1107.948 MB/sec
   8regs     :   774.192 MB/sec
   32regs    :   434.340 MB/sec
using fastest function: p5_mmx (1107.948 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 hda9 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 265064k swap-space (priority -1)
Comment 1 fons.rademakers 2000-04-11 11:51:59 EDT
For what it is worth, I've seen the same problem when I used
Mandrake 7.0 on an HP Netserver with PIII. It was also kernel 2.2.14
for i686 (the default Mandrake settings). I noticed the problem
easily, just a tar zxvf linux-2.2.14.tar.gz already failed with
random file corruptions. When I re-installed RH 6.1 the problems
disappeared.

-- Fons.Rademakers@cern.ch
Comment 2 Doug Ledford 2000-04-22 03:06:59 EDT
There are two distinct problems with that kernel on PIII machines.  One is that
some machines degenerate into hardware errors because the PIII optimizations in
that kernel are so much faster than standard operations.  The second is that
there is a bug in the task switching code in that kernel.  The i586 kernel
package that you installed does not solve the problem, it nly hides it some.
The errata kernel that has already been released backs out the PIII patches
which solves the problem.

Note You need to log in before you can comment on or make changes to this bug.