Bug 107231 - Fedora 0.95 - Graphic installation fails: Fatal IO error 104
Fedora 0.95 - Graphic installation fails: Fatal IO error 104
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 108609 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 20:04 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 14:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config.test file (4.03 KB, text/plain)
2003-10-16 17:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-10-15 20:04:41 EDT
Description of problem:
Running Fedora 0.95 graphic installation generate a "Fatal IO error 104"

Hardware:
AMD Athlon 600Mhz, 640 MB RAM 133Mhz, MotherBoard Asus K7V.
VGA: Guillemot Prophet II GTS (NVIDIA GeForce 2 GTS with 32MB DDR)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora 0.95 CD 1, press Enter, scan cd or skip scan, wait for the error.
2.
3.
    
Actual results:
The X server starts, The X mouse cursor appear, the mouse is working, but 
immediately exit with those errors/Messages:

Running anaconda, the Fedora Core system installer - please wait...
Probing for video card:   NVIDIA GeForce 2 GTS (generic)
Probing for monitor type:   Acer AC711
Probing for mouse type:   Generic - 2 Button Mouse (serial)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /tmp/ramfs done
        /mnt/source done
you may safely reboot your system

Pressing ALT+F3 the lasts lines in the log are:

* Running anaconda script /usr/bin/anaconda
* Display mode = g
* Method = cdrom://hdc:/mnt/source
* Started mini-wm

Expected results:


Additional info:
Comment 1 Jeremy Katz 2003-10-15 20:56:57 EDT
Were you switching vc's at the time?

Can you hit ctrl-S right at "install exited abnormally" and look at /tmp/X.log?
Comment 2 Need Real Name 2003-10-15 21:56:59 EDT
No, i was doing nothing, just waiting for the GUI to show.

Here are the important parts from X.log: (after the "Markers" explanation)

(++) Log file: "/tmp/ramfs/X.log", Time: Thu Oct 16 03:53:35 2003
(++) Using config file: "/tmp/XF86Config.test"
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "record" (module does not exist, 0)
error opening security policy file /etc/X11/server/SecurityPolicy
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
        No such device.
(EE) DevInputMice: cannot open input device
(EE) PreInit failed for input device "DevInputMice"
Could not init font path element unix/:7100, removing from list!
cat: //.Xauthority: No such file or directory

------- END

The mouse, serial, attached to the COM1, is a Logitech (MouseMan), 3 buttons, 
no scroll wheel.
Comment 3 Erno Härkönen 2003-10-15 22:25:50 EDT
I get the same error "XIO: fatal IO error 104", but only if I keep moving my
mouse when installation tries to start X server. I can reproduce this error
always and I get past this error only when I don't touch the mouse.

Hardware:
Athlon XP1800+, 256MB RAM DDR, MSI K7T266 Pro2
VGA: NVIDIA GeForce 3 Ti 200 128MB
Mouse: Logitech optical USB wheel mouse (recognised as 3 button USB during the
probe)
Comment 4 Need Real Name 2003-10-15 23:13:28 EDT
I did some tests.

With the Logitech serial mouse attached (moving or not), X fails to start.
I removed the mouse from the COM1 and attached a no-brand PS/2 mouse to the PC, 
and the graphical installation started.

I tried also with a Logitech USB 3 buttons with wheel (no optical), and the 
installation starts without problems, even moving the mouse. But the mouse is 
recognised as "Generic".

Now i have to verify if i can reach the end of the installation.

It seems the problem is with some Logitech mouse...
With RedHat 9 it worked without any problem. Maybe the mouse driver is changed?
Comment 5 Jeremy Katz 2003-10-15 23:49:31 EDT
Does /tmp/XF86Config look like it has the right configuration for a serial mouse?
Comment 6 Need Real Name 2003-10-16 11:28:29 EDT
Here is the XF86Config section regarding the mouse:

Section "InputDevice"
# (comment)
        Identifier "DevInputMice"
        Driver     "mouse"
        Option     "Protocol" "IMPS/2"
        Option     "Device" "/dev/input/mice"
        Option     "ZAxisMapping" "4 5"
        Option     "Emulate3Buttons" "no"
EndSection
Comment 7 Jeremy Katz 2003-10-16 14:57:41 EDT
There should be another mouse section with the serial mouse -- can you attach
the complete /tmp/XF86Config?
Comment 8 Need Real Name 2003-10-16 17:07:27 EDT
Created attachment 95239 [details]
XF86Config.test file

Yes, I missed the first part.
Here is attached the XF86Config.test
Comment 9 Brent Fox 2003-11-03 12:10:30 EST
*** Bug 108609 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2003-11-03 12:12:43 EST
Jeremy, I can reproduce this behavior on my test machine.  The problem
only occurs for me with a serial mouse.  Also note that the problem
does not occur when using the bootdisk.img floppy...maybe because the
boot floppies have a different kernel than the CDs?
Comment 11 Brent Fox 2003-11-03 12:14:03 EST
Also note that doing a TUI install is a workaround.  The serial mouse
will work fine in XFree86 after installation.
Comment 12 Greg Morgan 2004-01-11 19:05:48 EST
Thanks to for the work around.  I received this same error after
installing successfully on a ps/2 mouse machine AMD XP 2200+ PC.  I
thought the problem was an old matrox millenum II card with 4 megs of
ram first.  However, a nvidia on another PC AT machine on the same KVM
switch experienced the same problem right when anaconda started X. 
Both of these PCs are FIC mother boards with k6-2 AMD 500 mhz chips
and serial mice and AT keyboards. Another note of interest is that I
do have a PS 2 Logitech wheel mouse pluged into the serial port via a
PS 2 to serial adapter. The KVM switch serves these two PCs.  The boot
floppy was the solution.  

The boot.iso is a cool idea.  Just for grins I tried it with the same
failure.  Perhaps the boot ISO should be created in emulation mode for
old mother boards that don't implement eltorrito properly and with the
same kind of kernel that the boot floppy sports.

Perhaps the core 1 release notes should be updated too.  I checked
there first before bugzilla.  http://fedora.redhat.com/docs/release-notes/

Comment 13 Féliciano Matias 2004-05-03 07:33:16 EDT
Same problem here with FC2T3.
When i move the mouse during X11 starting, X11 crash (XIO:  fatal IO
error 104 ..... )

mouse : Generic - 3 Button Mouse (PS/2)
Athlon XP 1600+, 512 MB, main board MS-6380 V2 (K7T266 Pro2).
lspci :
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333 AGP]
00:05.0 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 03)
00:06.0 Multimedia controller: Sigma Designs, Inc. REALmagic Hollywood
Plus DVD Decoder (rev 02)
00:07.0 ATM network controller: STMicroelectronics ST70137 [Unicorn]
ADSL DMT Transceiver (rev 10)
00:08.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
00:09.0 Multimedia video controller: Brooktree Corporation Bt848 Video
Capture (rev 12)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC
AGP (rev 7a)
Comment 14 Marius Andreiana 2004-05-03 13:08:09 EDT
With FC1 I also observed anaconda crashing at this step with same
errors (while not touching the mouse) on 2 different systems.

The solution, on both, was not to skip CD verification! I checked the
1st CD, then continue installation and it was ok. Weird.
Comment 15 Jeremy Katz 2004-09-22 14:38:11 EDT
Serial mice are no longer supported with anaconda.
Comment 16 Larry Burton 2005-07-16 15:48:08 EDT
I understand this bug is closed, but I find the same behavior with fedoracore 4.

I have an ATI Mach64 3D Rage IIC video card, a microsoft wheel mouse (PS-2).

If I install from an FTP server, using the boot.iso image, I receive the following:

...
Probing for video card: ATI Mach64 3D Rage IIC
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start ...
...
X server started successfully
[about here, the screen goes black, as usual, button there is about a 20-30
delay, then I receive the following]
mini-wm: Fatal IO error 104 (Connection reset by peer) on X server :1.0.

[Now there is a blinking cursor underscore]

at this point a control-alt-delete will shut the system down and reboot

I have tried the ftp install from several different computers using the same
model of video card as well as other video cards.  This result is consistent
always when using the ATI card.

If I use the CD install, I have no errors and fc4 works fine (except on machines
with the Intel 845 chip where I experience the libvgahw.a bug ).

If I use a text mode install from ftp, the install fails while installing rpms.

If I use a 3D Banshee 9941 video card, I always get an error during rpm installs
 regardless of how I install.

Note You need to log in before you can comment on or make changes to this bug.