Bug 107243 - bad use of notification area
bad use of notification area
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 22:42 EDT by Sean Middleditch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 05:12:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Middleditch 2003-10-15 22:42:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014
Epiphany/1.0.1

Description of problem:
The RHN applet sits in the notification area, with a big bright blue icon, even
tho it's not notifying me of anything.  If it doesn't have anything to tell me,
it shouldn't be there.

Users can launch up2date in the menu, can configure up2date from the menu, and
they do not need a big blue distracting icon to do these things.

By not having the icon, the "switch" to the red "updates ready" icon will be
even more drastic, thus more likely to catch users attention.

Also see the numerous thread on usability@gnome.org and
desktop-devel-list@gnome.org on the proper usage of the notification area and
why it shouldn't be abused and used for the same purpose a normal applet would
work for.

Version-Release number of selected component (if applicable):
rhn-applet-2.1.0-1

How reproducible:
Always

Steps to Reproduce:
1. add notification area to panel
2. add rhn-applet to your session
3. update your system
4. observe the pointless blue Check icon
    

Actual Results:  pointless blue icon in the notification area.

Expected Results:  no icon in the nofication area, since there's nothing to
notify me about.

Additional info:

I'm using the version of the applet recently posted to the fedora list that
supports yum.  This behaviour does seem to be present in the normal version
(only utilizing up2date) as well, tho.
Comment 1 Daniel Veillard 2003-10-16 05:12:37 EDT
Well if some people have specific usability comments about the applet,
they should raise it here, not on the gnome.org lists, it is not a
GNOME software. 
W.r.t. the presence of the icon on the panel, if you don't want it,
then remove it. If you use the service, then it will be around. So
far I don't intent to change the way the applet behaves. If I had 
significant negative user feedback on the topic, then I would consider
that request, but balanced with the fact that this icon is identified
as a logo for the RHN services, its removal would need far more than just
engineering feedback.

Daniel
Comment 2 Sean Middleditch 2003-10-16 09:44:57 EDT
Can it be made a normal applet then and not a notification area icon?  Its
behaviour is perfectly fit for a normal applet.
Comment 3 Daniel Veillard 2003-10-16 10:19:25 EDT
No because it must work in both KDE and GNOME !

Daniel

Note You need to log in before you can comment on or make changes to this bug.