Bug 107244 - XmForm ignores the resize request of its child
XmForm ignores the resize request of its child
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openmotif (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 22:50 EDT by Tsukahara Ken
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 05:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tsukahara Ken 2003-10-15 22:50:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Create an application as follows.

TopLevel --- XmForm --- XmRowColumn -+-- XmPushButton
                                     +-- XmPushButton
                                     +-- XmPushButton
                                     +-- ...

The number of XmPushButtons is dynamic.
The size of the XmRowColumn shoud be adjusted on adding its children, but the 
size would be never changed. If the parent of XmRowColumn is a XmBulletinBoard, 
there is no problem. So it's XmForm's problem.

It seems to be a known bug (and fix) #176 of Open Motif Bug Database, and it 
works good for my case.
http://bugs.motifzone.net/long_list.cgi?buglist=176


Version-Release number of selected component (if applicable):
openmotif-2.2.2-14

How reproducible:
Always

Steps to Reproduce:
1. Create a window as above description. The XmRowColumn has only one child at 
first.
2. Add some children to the XmRowColumn dinamically.
3. The XmRowColumn should be grown, but never be resized.


Additional info:
Comment 1 Thomas Woerner 2004-04-20 05:08:56 EDT
You have two solutions:

1) replace the Form with a MainWindow
2) attach the Form and the RowColumn with ATTACH_FORM

This is not a bug.
Comment 2 Tsukahara Ken 2004-04-21 03:22:04 EDT
There would still be a compatibility problem between OpenMotif and 
CDE/Motif.
I have not seen the issue with CDE/Motif (on HP-UX and Solaris).
I think HP/SUN have applied some workaround to their own libXm...

Note You need to log in before you can comment on or make changes to this bug.