Bug 107265 - Please don't use hardcoded line breaks in redhat-config-network messages
Please don't use hardcoded line breaks in redhat-config-network messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
http://developer.gnome.org/doc/tutori...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 06:44 EDT by Christian Rose
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 09:21:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2003-10-16 06:44:42 EDT
#. widget.set_position(0)
#: src/netconfpkg/gui/CipeInterface.py:325
msgid ""
"You must enter a secret key \n"
"or generate one"

#: src/netconfpkg/gui/maindialog.py:358
msgid ""
"Changes are saved.\n"
"You may want to restart\n"
"the network and network services\n"
"or restart the computer."

#: src/netconfpkg/gui/maindialog.py:1537
msgid ""
"Sorry, there is nothing to be edited,\n"
"or this type cannot be edited yet."


Please don't hard code line breaks like this in messages, but instead allow
for automatic line wrapping of messages. This not only helps translators
for several reasons (as described in detail on
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#line-breaks),
but it also improves accessibility since users can use other fonts and
larger font sizes without messages becoming ugly or even unreadable.
Comment 1 Christian Rose 2003-10-16 07:16:42 EDT
Also true for:

#: src/netconfpkg/gui/editipsec.glade.h:30
msgid ""
"You will now be guided through the\n"
"setup of the IPsec connection."

Note You need to log in before you can comment on or make changes to this bug.