Bug 107274 - Loss of IP tie-breaker vote not handled.
Loss of IP tie-breaker vote not handled.
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 09:44 EDT by Lon Hohberger
Modified: 2009-04-16 16:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 13:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2003-10-16 09:44:13 EDT
NOTE: Double-Fault.  Red Hat does not generally support this kind of situation.

Behavior in event of loss of IP-tie-breaker is undefined.

Actual results:
Undefined/Unhandled behavior.

Expected results:
Undefined.

Additional info:
Consider monitoring the IP tie-breaker more proactively when a half-split occurs
in the cluster; handle in a similar manner to loss of disk-tie-breaker (ie, loss
of quorum at that point).
Comment 2 Lon Hohberger 2003-10-28 10:30:15 EST
Cluster handles loss of quorum when tie breaker IP is no longer available. 
However, since this is a double-fault, the cluster requires either:

(a) a majority of real members to return to normal operation afterward (simply
bring the tiebreaker back online is not sufficient), or

(b) restarting the members after the tiebreaker IP comes back online.
Comment 3 Larry Troan 2003-11-04 11:50:07 EST
PER BUG 108148
------ Additional Comments From lhh@redhat.com  2003-10-28 10:26 -------
CVS build of clumanager:

http://people.redhat.com/lhh/.testing/clumanager-1.2.5-0.1.89.2.8.i386.rpm
http://people.redhat.com/lhh/.testing/clumanager-1.2.5-0.1.89.2.8.src.rpm

Fixes: #103721, #106465, #107274, #107276, #108148
Comment 5 Suzanne Hillman 2004-01-14 13:24:48 EST
Tested, closing as errata.
Comment 6 Lon Hohberger 2007-12-21 10:10:09 EST
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3

Note You need to log in before you can comment on or make changes to this bug.