This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 10729 - kppp doesn't work after upgrade to 6.2
kppp doesn't work after upgrade to 6.2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 10054 11027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 13:38 EDT by Albert Strasheim
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 00:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2000-04-11 13:38:01 EDT
Hello,

For some reason, after upgrading from 6.1 to 6.2 kppp dies with the
following after I enter my root password into userhelper's prompt (I am
running as a regular user):

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
kppp: cannot connect to X server :0.0

However, when I do su -c kppp and type in my root password, kppp connects
to the X server and runs fine.

What gives?
Comment 1 Aleksey Nogin 2000-05-21 17:24:59 EDT
Here is a solution.

1) Add the following line to /etc/security/pam_env.conf
XAUTHORITY      DEFAULT=${HOME}/.Xauthority

2) Add the following line to /etc/pam.d/kppp , right before all other "auth"
lines:
auth       optional     /lib/security/pam_env.so

Works for me!
Comment 2 David Lawrence 2000-05-22 00:25:59 EDT
*** Bug 10054 has been marked as a duplicate of this bug. ****** Bug 11027 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2000-06-23 08:16:28 EDT
Change "SESSION=false" to "SESSION=true" in /etc/security/console.apps/kppp.
This is done in rawhide.

Note You need to log in before you can comment on or make changes to this bug.