Bug 107335 - gnome-terminal cannot display utf8 serial installs properly
gnome-terminal cannot display utf8 serial installs properly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vte (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 21:17 EDT by Mike McLean
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-1 (35.15 KB, image/png)
2003-10-16 21:18 EDT, Mike McLean
no flags Details
screenshot-5 (33.36 KB, image/png)
2003-10-16 21:19 EDT, Mike McLean
no flags Details
screenshot-8 (42.76 KB, image/png)
2003-10-16 21:20 EDT, Mike McLean
no flags Details

  None (edit)
Description Red Hat Bugzilla 2003-10-16 21:17:51 EDT
* Taroon-re1007.RC1.0 ws
* gnome-terminal-2.2.2-1
* vte-0.11.10-3
* ckermit-8.0.209-2
* xterm-179-5.EL

If you run kermit in a gnome-terminal and try to perform a utf8 serial install
the display will get corrupted with each draw operation.  This used to work.

FWIW, running kermit in an xterm works fine (at least in english).  

Also note that non-utf8 serial installs work fine under kermit + gnome-terminal.
Comment 1 Red Hat Bugzilla 2003-10-16 21:18:44 EDT
Created attachment 95248 [details]
screenshot-1
Comment 2 Red Hat Bugzilla 2003-10-16 21:19:33 EDT
Created attachment 95249 [details]
screenshot-5
Comment 3 Red Hat Bugzilla 2003-10-16 21:20:03 EDT
Created attachment 95250 [details]
screenshot-8
Comment 4 Red Hat Bugzilla 2003-10-16 22:06:57 EDT
This has been happening since B2 I believe... I always thought it was anaconda.
 Anaconda folks explained that it was general terminal emulator funkiness going
on since it works fine in xterm and on the console.
Comment 5 Red Hat Bugzilla 2004-08-16 11:14:38 EDT
I had filed bug 129942 for gnome terminal "corruption" on serial 
install for Altix.  Although the screen is corrupted in different
ways than mentioned in this bug, the concept is the same.  Firing off
the install from an xterm solved the problem.

Adding myself and Jesse to the cclist.
Comment 6 Red Hat Bugzilla 2007-10-19 15:33:51 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.