Bug 107345 - Max Screen Resolution not detected
Summary: Max Screen Resolution not detected
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-17 05:08 UTC by Gantry York
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 03:19:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gantry York 2003-10-17 05:08:35 UTC
Description of problem:

The Screen Resolution (/etc/X11/XF86Config) tool recognizes that I am using a
Riva TNT with a Dell 1626HT monitor, but 1152x864x'millions of colors' at 85Hz
is the highest it will configure it to go.  Yet it can be set for greater than
this.  In fact, when I was running RH9, I had it set to 1600x1200 with the same
hardware configuration.


Version-Release number of selected component (if applicable):

Fedora Core "Severn" beta - Test3


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:

I expect it to have 1600x1200 as a possible choice for screen resolution.


Additional info:

Comment 1 Jonathan Blandford 2003-10-17 15:09:53 UTC
Does your XF86Config file actually have the larger resolutions in its Screen
section?

Comment 2 Alexander Larsson 2003-10-17 17:44:46 UTC
This is probably an X issue. What does "xrandr" say if you run it on the command
line?


Comment 3 Gantry York 2003-10-20 13:16:58 UTC
Reply to Comment #1 (by J Blanford)

No, but that is the whole point.  The installation should detect all the
possible resolutions and create an XF86Conig with all those possible resolutions.


Reply to Comment #2 (by A Larsson)

 SZ:    Pixels          Physical       Refresh
*0   1152 x 864    ( 380mm x 293mm )  *85   75
 1   1024 x 768    ( 380mm x 293mm )   84   75   70   60   87
 2    800 x 600    ( 380mm x 293mm )   85   75   72   70   65   60   56
 3    640 x 480    ( 380mm x 293mm )   85   75   72   60
 4   1152 x 768    ( 380mm x 293mm )   54
 5    960 x 720    ( 380mm x 293mm )   60
 6    928 x 696    ( 380mm x 293mm )   60
 7    896 x 672    ( 380mm x 293mm )   75   60
 8    960 x 600    ( 380mm x 293mm )   72
 9    832 x 624    ( 380mm x 293mm )   74
 10   700 x 525    ( 380mm x 293mm )   85   74   70   59
 11   640 x 512    ( 380mm x 293mm )   85   75   60
 12   720 x 400    ( 380mm x 293mm )   85
 13   640 x 400    ( 380mm x 293mm )   85
 14   576 x 432    ( 380mm x 293mm )   85   75
 15   640 x 350    ( 380mm x 293mm )   85
 16   576 x 384    ( 380mm x 293mm )   54
 17   512 x 384    ( 380mm x 293mm )   84   75   70   60   87
 18   416 x 312    ( 380mm x 293mm )   74
 19   400 x 300    ( 380mm x 293mm )   85   75   72   60   56
 20   320 x 240    ( 380mm x 293mm )   85   75   72   60
 21   360 x 200    ( 380mm x 293mm )   85
 22   320 x 200    ( 380mm x 293mm )   85
 23   320 x 175    ( 380mm x 293mm )   85
Current rotation - normal
Current reflection - none
Rotations possible - normal
Reflections possible - none


Comment 4 Michael Fulbright 2003-10-20 18:30:23 UTC
Anaconda only tries to setup a basic mode that is known to work. The
redhat-config-xfree86 tool is used to modify this selection.

Due to how XFree86 servers work you cannot write out the higher resolution modes
in the XF86Config file or you will get a virtual desktop. Kinda makes xrandr
useless.

Comment 5 Tino Meinen 2003-10-23 17:18:52 UTC
Same situation with my IIyama Vision Master Pro510 (21") and Nvidia Geforce3 card.
Comparing RH9 XFree86 with the one from FCtest3 shows: 

[root@node10a62 root]# diff -u -w /etc/X11/XF86Config /mnt/fedora/etc/X11/XF86Config
--- /etc/X11/XF86Config 2003-10-11 11:59:48.000000000 +0200
+++ /mnt/fedora/etc/X11/XF86Config      2003-10-22 23:16:16.000000000 +0200
@@ -102,7 +102,6 @@
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 3 (generic)"
-       VideoRam    65536
 EndSection
  
 Section "Screen"
@@ -112,7 +111,7 @@
        DefaultDepth     24
        SubSection "Display"
                Depth     24
-               Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
"640x480"
+               Modes    "1024x768" "800x600" "640x480"
        EndSubSection
 EndSection

------------
So, the max resolution with anaconda and with redhat-config-xfree86 is 1024x786
wich is not a lot for a 21" monitor.



Comment 6 Brent Fox 2004-03-04 18:28:46 UTC
Gantry: As root, run '/usr/sbin/ddcprobe' and paste the results here.

Comment 7 Brent Fox 2004-03-05 03:19:56 UTC
Closing due to lack of information.


Note You need to log in before you can comment on or make changes to this bug.