Bug 107350 - Boot floppy image written to hard disk
Boot floppy image written to hard disk
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-17 04:29 EDT by Martin Wilck
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.34-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 16:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/syslog of installation (10.45 KB, text/plain)
2003-10-17 04:31 EDT, Martin Wilck
no flags Details
anaconda log from installation (6.84 KB, text/plain)
2003-10-17 04:32 EDT, Martin Wilck
no flags Details
/proc/partitions (556 bytes, text/plain)
2003-10-17 04:34 EDT, Martin Wilck
no flags Details
/ptoc/scsi/scsi (809 bytes, text/plain)
2003-10-17 04:34 EDT, Martin Wilck
no flags Details

  None (edit)
Description Martin Wilck 2003-10-17 04:29:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
This is a funny one - converts a hard disk to a floppy.

RH 9 install on a SCSI system needing a driver disk (with aic79xx 1.3.8). The
system has no legacy floppy drive and no CD drive, it uses USB CD and floppy
instead.

When the boot floppy is being written, the device file /tmp/floppy points to the
wrong device (hard disk) . Thus, instead of writing the boot floppy, the fresh
installation on the hard disk is overwritten.

Version-Release number of selected component (if applicable):
anaconda-9.0-4

How reproducible:
Always

Steps to Reproduce:
1.Do a fresh RH9 install from USB floppy disk on a SCSI hard disk
2.Leave "create boot floppy" checked at end of installation
3.Reboot, remove CD and floppy
    

Actual Results:  The boot floppy is empty.
The system comes up with a "SYSLINUX" prompt from the hard disk.

Expected Results:  The USB floppy disk should have been written, and a GRUB boot
prompt should appear when booting from hard disk.


Additional info:

I will attach some log files from the installation.

Additional quirk: when trying to reinstall after this problem has occured, the
partitioning tool gets massively irritated by the fact that the first hard disks
has no partition table but carries a floppy image.
The only workaround is a "dd if=/dev/zero of=/dev/sda bs=1k count=1440" from the
shell.
Comment 1 Martin Wilck 2003-10-17 04:31:21 EDT
Created attachment 95254 [details]
/tmp/syslog of installation
Comment 2 Martin Wilck 2003-10-17 04:32:05 EDT
Created attachment 95255 [details]
anaconda log from installation
Comment 3 Martin Wilck 2003-10-17 04:34:12 EDT
Created attachment 95256 [details]
/proc/partitions
Comment 4 Martin Wilck 2003-10-17 04:34:48 EDT
Created attachment 95257 [details]
/ptoc/scsi/scsi
Comment 5 Martin Wilck 2003-10-17 04:37:09 EDT
Here an excerpt from /tmp:
total 531
-rwxr-xr-x    1 root     0            1539 Oct 17 10:00 X.log
-rw-r--r--    1 root     0            3963 Oct 17  2003 XF86Config.test
-rw-rw-r--    1 root     0          190650 May 14 16:49 aic79xx.o
-rw-r--r--    1 root     0            7002 Oct 17 10:04 anaconda.log
brw-------    1 root     0         11,   0 Oct 17 10:04 cdrom
brw-------    1 root     0          8,   0 Oct 17  2003 dddev
drwxr-xr-x    2 root     0            1024 Oct 17  2003 drivers
brw-------    1 root     0          8,   0 Oct 17 10:04 floppy
-rw-r--r--    1 root     0              54 Oct 17  2003 isoinfo

See that both "dddev" and "floppy" erroneously refer to /dev/sda.
Comment 6 Martin Wilck 2003-10-17 04:40:03 EDT
Obviously the /tmp/floppy and /tmp/dddev devices do not reflect the fact that 
in RH9 the usb-storage driver is unloaded before loading any SCSI drivers (which
is of course correct).
Comment 7 Jeremy Katz 2003-10-17 11:18:50 EDT
This is due to kudzu's probing getting confused.
Comment 8 Bill Nottingham 2003-10-17 16:31:35 EDT
Fixed in 1.1.34-1.
Comment 9 Jay Turner 2004-01-16 12:15:44 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-344.html

Note You need to log in before you can comment on or make changes to this bug.