Bug 10738 - RFE:Allow passing options to pcmcia in expert mode
RFE:Allow passing options to pcmcia in expert mode
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 20:29 EDT by vlmoran
Modified: 2007-03-26 23:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 02:25:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vlmoran 2000-04-11 20:29:55 EDT
When I try doing a bootnet install, my Twinhead laptop freezes when it
gets to the first step after typing "text" into the initial screen.

This problem is related to the memory address of the intel i82365 pcmcia
controller.  The problem has existed on this laptop (and others of the same
type) since version 6.0.

I got around this problem in version 6.1's installer by not doing a net
install.  I Installed from the CD-ROM and then changed the pcmcia.opts file
before letting the machine reboot.

Changing pcmcia.opts to the following values will allow the system to boot.
PCMCIA=yes
PCIC=i82365
PCIC_OPTS="i365_base=0x300 do_scan=
poll_interval=100"
CORE_OPTS=

I'd like to be able to complete the bootnet install.  One way to get around
this problem would be to allow us to set these parameters while were
installing, before the machine tries to initialize the PC Card controller.
 Another way, and probably the best way to fix this problem, is to find a
way to make the probe (which is what is freezing, because its probing the
wrong address) give up after some time and try other probable and common
addresses.

Vicor Moran
Comment 1 Jay Turner 2000-04-12 07:24:59 EDT
I have forwarded this report to a developer for further action.
Comment 2 Erik Troan 2000-08-07 17:45:54 EDT
Our UI is frozen, but this does need resolving.
Comment 3 Michael Fulbright 2001-09-14 12:33:40 EDT
Have you been able to reproduce this problem with 7.1 or 7.0?
Comment 4 Jeremy Katz 2003-01-10 02:25:26 EST
Closing due to lack of activity

Note You need to log in before you can comment on or make changes to this bug.