This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1074307 - SELinux is preventing /usr/sbin/runuser from 'write' accesses on the fifo_file .
SELinux is preventing /usr/sbin/runuser from 'write' accesses on the fifo_file .
Status: CLOSED DUPLICATE of bug 864143
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
abrt_hash:cfb46a570b00d02ad041b64a739...
:
: 1071508 1071549 1074662 1075778 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-09 11:13 EDT by Jared Smith
Modified: 2014-06-19 18:53 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 18:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2014-03-09 11:13:36 EDT
Description of problem:
Just saw this pop up randomly this morning.
SELinux is preventing /usr/sbin/runuser from 'write' accesses on the fifo_file .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that runuser should be allowed write access on the  fifo_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep runuser /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
Target Context                system_u:object_r:systemd_logind_sessions_t:s0
Target Objects                 [ fifo_file ]
Source                        runuser
Source Path                   /usr/sbin/runuser
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           util-linux-2.24.1-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-127.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.13.5-202.fc20.x86_64 #1 SMP Mon
                              Mar 3 19:08:00 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-03-09 11:12:01 EDT
Last Seen                     2014-03-09 11:12:01 EDT
Local ID                      5274d95a-d044-4657-997b-da5aa1156fb1

Raw Audit Messages
type=AVC msg=audit(1394377921.354:1317): avc:  denied  { write } for  pid=7821 comm="runuser" path="/run/systemd/sessions/20.ref" dev="tmpfs" ino=1486663 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file


type=SYSCALL msg=audit(1394377921.354:1317): arch=x86_64 syscall=recvmsg success=yes exit=172 a0=3 a1=7fffcc76a480 a2=40000000 a3=1 items=0 ppid=7820 pid=7821 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=20 tty=(none) comm=runuser exe=/usr/sbin/runuser subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)

Hash: runuser,logrotate_t,systemd_logind_sessions_t,fifo_file,write

Additional info:
reporter:       libreport-2.1.12
hashmarkername: setroubleshoot
kernel:         3.13.5-202.fc20.x86_64
type:           libreport
Comment 1 Lennart Poettering 2014-06-17 08:07:48 EDT
*** Bug 1074662 has been marked as a duplicate of this bug. ***
Comment 2 Lennart Poettering 2014-06-17 08:07:53 EDT
*** Bug 1075778 has been marked as a duplicate of this bug. ***
Comment 3 Lennart Poettering 2014-06-17 08:12:38 EDT
*** Bug 1071508 has been marked as a duplicate of this bug. ***
Comment 4 Lennart Poettering 2014-06-17 08:12:43 EDT
*** Bug 1071549 has been marked as a duplicate of this bug. ***
Comment 5 Lennart Poettering 2014-06-19 18:53:16 EDT

*** This bug has been marked as a duplicate of bug 864143 ***

Note You need to log in before you can comment on or make changes to this bug.