Bug 107473 - qt incorrectly handles fonts when X is in dual head xinerama mode.
qt incorrectly handles fonts when X is in dual head xinerama mode.
Status: CLOSED DUPLICATE of bug 109351
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-18 18:22 EDT by Dan Nuffer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of messed up fonts in Xinerama mode. (403.82 KB, image/png)
2003-10-18 18:34 EDT, Dan Nuffer
no flags Details
Screen shot of what single head looks like (79.87 KB, image/png)
2003-10-18 18:34 EDT, Dan Nuffer
no flags Details
XF86Config used in single head mode (3.23 KB, text/plain)
2003-10-18 18:35 EDT, Dan Nuffer
no flags Details
XF86Config used in dual mode (3.84 KB, text/plain)
2003-10-18 18:36 EDT, Dan Nuffer
no flags Details

  None (edit)
Description Dan Nuffer 2003-10-18 18:22:43 EDT
Description of problem:
Fonts just look plain ugly in any qt or kde application.  This doesn't seem to
be a problem for other things (mozilla, gnome/gtk apps, OpenOffice).

Version-Release number of selected component (if applicable):
qt-3.1.2-14

How reproducible:
Always

Steps to Reproduce:
1. Turn on dual head xinerama.
2. Run Konsole, notice the font looks bad.
3. Pick Settings->Font->Custom.  Notice that the dialog has a *different* list
of fonts.  Many of them seem to be broken, when you click on them, the font
doesn't change.
    
Actual results:
Fonts are messed up.

Expected results:
Fonts should work the same as in single head mode.

Additional info:
Screen shots and XFree86Config files will be attached.
Comment 1 Dan Nuffer 2003-10-18 18:34:21 EDT
Created attachment 95287 [details]
Screen shot of messed up fonts in Xinerama mode.
Comment 2 Dan Nuffer 2003-10-18 18:34:57 EDT
Created attachment 95288 [details]
Screen shot of what single head looks like
Comment 3 Dan Nuffer 2003-10-18 18:35:40 EDT
Created attachment 95289 [details]
XF86Config used in single head mode
Comment 4 Dan Nuffer 2003-10-18 18:36:05 EDT
Created attachment 95290 [details]
XF86Config used in dual mode
Comment 5 Ngo Than 2003-10-29 07:34:52 EST
It would be nice if you could only test qt application.

To do that, you have to start for example GNOME Eviroment and then
try to start qtconfig. Does this problem still exist?
Comment 6 Ngo Than 2003-11-26 13:15:58 EST
please take a look in 109351

*** This bug has been marked as a duplicate of 109351 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:59:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.