Bug 107502 - Evo fails to connect to remote ISPs SMTP server.
Summary: Evo fails to connect to remote ISPs SMTP server.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-19 14:48 UTC by Dave Jones
Modified: 2015-01-04 22:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 01:06:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Jones 2003-10-19 14:48:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031010
Galeon/1.3.9

Description of problem:
When trying to send mail, Evo pops up a dialog with..

Error while performing operation:
Could not connect to smtp.aaisp.net.uk
(port 25): Bad file descriptor

Routing is fine, and I can connect to the smtp port of said server fine
with telnet.

This seems to be a recent breakage, as test3 worked. Its worth noting that this
broke after the recent IPV6 changes, and doing a telnet does this...

(15:43:55:davej@veebl:davej)$ telnet smtp.aaisp.net.uk 25
Trying 2001:8b0::d9a9:1411...
Trying 217.169.20.17...
Connected to smtp.aaisp.net.uk.
Escape character is '^]'.
220 smtp.aaisp.net.uk ESMTP Exim 4.22 Sun, 19 Oct 2003 15:45:26 +0100

(Note it tries the ipv6 address first). There is no ipv6 interface on this box.



Version-Release number of selected component (if applicable):
1.4.5-4

How reproducible:
Always

Steps to Reproduce:
1. Try to send mail to mailserver with ipv6 IP with no ipv6 interface
2.
3.
    

Actual Results:  Mail gets sent to the ipv4 address.


Expected Results:  I'm guessing it's trying to route it to the ipv6 interface,
doesn't find one, and goes bang with the "bad file descriptor"


Additional info:

Comment 1 Jeremy Katz 2003-10-22 21:31:23 UTC
-5 should fix this.

Comment 2 Dave Jones 2003-11-11 01:06:04 UTC
fixed


Note You need to log in before you can comment on or make changes to this bug.