Bug 107510 - symlink points to /dev/hdc instead of /dev/scd0 for a cd-rw using ide-scsi
symlink points to /dev/hdc instead of /dev/scd0 for a cd-rw using ide-scsi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 14:53 EDT by Need Real Name
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 17:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-10-19 14:53:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i586; U;) Gecko/20030131

Description of problem:
My system has a cd-rw on /dev/hdc. After a fresh install of Fedora Core test 3,
grub is set to pass the appropriate ide-scsi parameters to the kernel. However,
the symlink /dev/cdrom points to /dev/hdc instead of /dev/scd0, so the cd-rw is
not mountable by nautilus. This same hardware works fine with my current Redhat
9 installation (same machine, dual boot). I have performed the installation of
Fedora Core test 3 twice, with the same result both times. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core test 3
2. Try to mount a cd with nautilus


Actual Results:  Nautilus will give a media error when attempting to mount the
cd. /dev/cdrom will be pointing to /dev/hdc instead of /dev/scd0. 

Expected Results:  /dev/cdrom should be pointing to /dev/scd0, so nautilus will
be able to mount the cdrom. 

Additional info:

This system also has Redhat 9 on it, and it works fine.
Comment 1 Bill Nottingham 2003-10-20 00:05:49 EDT
The kudzu service *is* enabled, correct? Is the ide-scsi module getting loaded
correctly?
Comment 2 Need Real Name 2003-10-21 02:04:08 EDT
I just did some checking, and I think I have it figured out. 

To answer your questions, kudzu was enabled and ide-scsi was working. HOWEVER,
the graphical boot was covering some important information. It turns out that
when kudzu ran during the boot, it was waiting for some user intervention
underneath the splash screen. I have a serial intellimouse on my system (yes, it
is old), and kudzu thought it had been removed (it has not).  When it never
received any user intervention, it timed out and continued booting, apparently
without ever taking care of the cd-rw configuration. Having realized this, I ran
kudzu from the command line and told it to keep the intellimouse configuration.
On the next boot, kudzu went through its hardware checks without any requests
for user intervention, and the cd-rw was properly configured (/dev/cdrom ->
/dev/scd0, useable by normal users). 

I imagine that I haven't had this problem before because, the first time I
booted RH9, I saw the kudzu prompt since it isn't covered by a graphical boot
screen, told it to keep the intellimouse configuration, and everything worked
just fine. Perhaps the graphical boot needs a way to know that something is
waiting for user input and then automatically show the details?
Comment 3 Bill Nottingham 2003-10-22 17:26:01 EDT
FWIW, the serial mouse stuff should work right again with
kudzu-1.1.35-1, and also it will automatically show details if kudzu
pops up.

So this instance should be fixed.

Note You need to log in before you can comment on or make changes to this bug.