Bug 107511 - SRPM does not compile
SRPM does not compile
Status: CLOSED DUPLICATE of bug 115953
Product: Fedora
Classification: Fedora
Component: compat-gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 15:03 EDT by Matteo Corti
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for parse.y (see the current gcc sources) (446 bytes, patch)
2003-10-19 15:35 EDT, Matteo Corti
no flags Details | Diff
repairs spec-file to compile on i486 and higher (1.02 KB, patch)
2003-12-10 10:30 EST, Helmut Schlattl
no flags Details | Diff

  None (edit)
Description Matteo Corti 2003-10-19 15:03:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
The SPRM fails to compile:

make[3]: Entering directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc/cp'
expect 33 shift/reduce conflicts and 58 reduce/reduce conflicts.
cd ../../../gcc/cp; bison  -d -o parse.c parse.y
parse.y:2057.15-23: integer out of range: `$<ttype'
make[3]: *** [../../../gcc/cp/parse.c] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc/cp'
make[2]: *** [../../gcc/cp/parse.c] Error 2
make[2]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc'
make[1]: *** [bootstrap-lean] Error 2
make[1]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc'
make: *** [bootstrap-lean] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.43686 (%build)


Version-Release number of selected component (if applicable):
compat-gcc-7.3-2.96.118

How reproducible:
Always

Steps to Reproduce:
1. rpm -i compat-gcc-7.3-2.96.118.src.rpm
2. rpmbuild -bb /usr/src/redhat/SPECS/compat-gcc.spec

    

Actual Results:  
make[3]: Entering directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc/cp'
expect 33 shift/reduce conflicts and 58 reduce/reduce conflicts.
cd ../../../gcc/cp; bison  -d -o parse.c parse.y
parse.y:2057.15-23: integer out of range: `$<ttype'
make[3]: *** [../../../gcc/cp/parse.c] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc/cp'
make[2]: *** [../../gcc/cp/parse.c] Error 2
make[2]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc'
make[1]: *** [bootstrap-lean] Error 2
make[1]: Leaving directory
`/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux7/gcc'
make: *** [bootstrap-lean] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.43686 (%build)

Expected Results:  Compiled RPMs

Additional info:
Comment 1 Matteo Corti 2003-10-19 15:35:31 EDT
Created attachment 95299 [details]
Patch for parse.y (see the current gcc sources)

This fixes parse.y as in the new GCC source trees
Comment 2 Helmut Schlattl 2003-12-10 10:30:26 EST
Created attachment 96444 [details]
repairs spec-file to compile on i486 and higher
Comment 3 Helmut Schlattl 2003-12-10 10:34:57 EST
forgot to add: 
- attachment id=96444 needs the patch from corti@inf.ethz.ch!
- compat-gcc does not compile with bison-1.875-5, but needs bison-1.35

Error with bison-1.875:
     
cd ../../gcc/java && $bison -t  --name-prefix=java_ \
    -o parse.c ./parse.y
./parse.y:493.10-15: type redeclaration for interface_type_list
./parse.y:502.10-15: type redeclaration for class_member_declaration
./parse.y:515.10-15: type redeclaration for
unary_expression_not_plus_minus
make[2]: *** [../../gcc/java/parse.c] Error 1
make[2]: Leaving directory
`/data/system/BUILD/gcc-2.96-20000731/obj-i586-redhat-linux7/gcc'
make[1]: *** [bootstrap-lean] Error 2
make[1]: Leaving directory
`/data/system/BUILD/gcc-2.96-20000731/obj-i586-redhat-linux7/gcc'
make: *** [bootstrap-lean] Error 2
Comment 4 Miloslav Trmac 2004-02-17 06:39:48 EST

*** This bug has been marked as a duplicate of 115953 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:59:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.