Bug 107535 - Fix serial driver oops
Fix serial driver oops
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: 122950
  Show dependency treegraph
 
Reported: 2003-10-20 04:01 EDT by David Joo
Modified: 2013-07-02 22:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kernel Panic dump (2.95 KB, text/plain)
2003-10-20 04:02 EDT, David Joo
no flags Details
ksymoops message (5.09 KB, text/plain)
2003-10-20 04:04 EDT, David Joo
no flags Details
attempt to fix oops (320 bytes, patch)
2004-07-14 21:56 EDT, Jeff Garzik
no flags Details | Diff

  None (edit)
Description David Joo 2003-10-20 04:01:34 EDT
Description of problem:
Kernel Panics, if the system has Xircom CardBus card.

Version-Release number of selected component (if applicable):
Taroon-re1007.RC1.0 (2.4.21-4.EL)

How reproducible:
Every time,

Steps to Reproduce:
1. Install Taroon
2. reboot
3.
    
Actual results:
Kernel Panics

Expected results:
Should be able to use as normal

Additional info:
It seems it has a problem with "serial.c"'s pci_siig10x_fn
I am attatching kernel panic dump "oops" and ksymoops messages.
Comment 1 David Joo 2003-10-20 04:02:52 EDT
Created attachment 95308 [details]
Kernel Panic dump
Comment 2 David Joo 2003-10-20 04:04:14 EDT
Created attachment 95309 [details]
ksymoops message

It is an output value from ksymoops.
Comment 3 Bill Nottingham 2003-10-20 18:45:12 EDT
Why would the xircom_cb card be in the pci_siig10x_fn function?
Comment 5 David Carrigan 2003-11-14 14:41:22 EST
This bug still exists in RHEL 3 (2.4.21-4.EL) A/ES.
How can we get Arjan the combo card?  
Comment 6 David Carrigan 2003-11-14 14:45:31 EST
Sorry, I mistakenly closed this bug... another oops.
Comment 7 Yu Shao 2003-11-15 02:26:12 EST
Please also see bug 103337 which was reported earlier.
Comment 8 Steve Bonneville 2003-11-17 10:42:34 EST
To fill in some information....

We're seeing this with the Xircom RBEM56G-100 PCMCIA card, which
appears to use the xircom_cb driver.  This is also known as the
"Xircom RealPort CardBus Ethernet 10/100+Modem 56" card.  This driver
is in the supported kernel package.  If the card is inserted at boot,
the kernel panics with a fatal exception at pcmcia service startup. 
If the system is running without the card, the kernel panics instantly
on card insertion.  Simply loading the xircom_cb module without the
card inserted does not trigger the kernel panic.

Tested on a Dell Latitude CPx.  GLS has a ton of these cards that were
formerly in training equipment that I expect we can loan engineering
and QA.

I'm changing severity to high, because these cards are essentially
useless until this bug is repaired.
Comment 9 Steve Bonneville 2003-11-17 11:59:31 EST
For what it's worth:

Training also happened to have a second similar card handy, an
externally identical Xircom REM56G-100 (Xircom RealPort Ethernet
10/100+Modem 56).  This card uses the unsupported xirc2ps_cs driver,
and the supported serial_cs driver.  It seems to function normally (if
the kernel-unsupported package which includes it is installed).

The CardBus card that's broken does work in a RHL 9 installed laptop,
so this is a regression.
Comment 10 Tim Burke 2003-12-16 10:29:53 EST
*** Bug 106341 has been marked as a duplicate of this bug. ***
Comment 14 Florian Brand 2004-02-22 03:12:48 EST
BTW in FC1 the card works nicely again.
On possible related matters a conceptronics USB2.0 card also panics
the kernel when on of it's usb ports is accessed (works fine with
FC1), so could this be a more generic cardbus problem?
Comment 15 Greg Sanders 2004-04-15 05:54:55 EDT
This has solved my install problems, although without my Xircom card 
I am without LAN access, so either I try to wait for a fix (I am new 
to Linux) or buy another card.

What do you think I should do?

Thanks.
Comment 17 Blurred Vision 2004-05-01 22:24:40 EDT
This is killing me too.  Any ideas on an expected fix date?
Comment 18 Blurred Vision 2004-05-01 22:24:55 EDT
This is killing me too.  Any ideas on an expected fix date?
Comment 20 Thomas 2004-05-27 05:50:50 EDT
Any news! I have the same bl**dy problem!
Comment 21 James Oliver 2004-06-17 05:25:23 EDT
I'd like to add my voice to this bug - it is a show stopper.

Is there any progress at all?  The last RedHat comment is ~ 4 months
ago which would seem to indicate that this has stalled.  Jeff - are
you able to provide a status update?
Comment 23 Jeff Garzik 2004-07-14 21:56:38 EDT
Created attachment 101929 [details]
attempt to fix oops
Comment 24 Jeff Garzik 2004-07-14 21:58:13 EDT
Whoever merged the HP Diva patch screwed up the entire list of PCI
serial devices.  This affects not only Xircom, but all PCI serial
devices that follow HP Diva.

Please test the patch I just attached.
Comment 25 AlanCB 2004-07-15 10:46:22 EDT
could u please tell me how to install this patch ?
cheers
so far i edited the file maually and added the two # lines (not sure
how they will help however....)
Comment 26 Matthew Galgoci 2004-07-20 12:43:04 EDT
The patch attached in comment fixes the problem with both the 16bit
and 32bit versions of the xircom modem/ethernet combo cards. I've not
tested any other scenarios other than initializing the modem and
sending at strings to make sure the modem is thinking.
Comment 27 Ernie Petrides 2004-08-13 00:06:30 EDT
A fix for this problem has just been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-19.EL).
Comment 28 John Flanagan 2004-09-02 00:30:55 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.