Bug 107564 - Cannot Compile Kernels
Cannot Compile Kernels
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 13:34 EDT by Edward Simmonds
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 13:40:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Simmonds 2003-10-20 13:34:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
Latest kernel (2.4.22-1.2097) does not compile. In fact, I have been unable to
compile ANY kernel in Fedora, including a vanilla 2.4.22 from kernel.org or any
of the kernel-sources provided by RedHat.  I am using the i686 config right out
of the configs directory in each case.  
I am using gcc32.

Two examples follow.  These both use the default i686 config.


latest kernel (2097) (i686 config from configs directory):

make[3]: Leaving directory `/usr/src/linux-2.4.22-1.2097.nptl/fs/nls'
make[2]: Leaving directory `/usr/src/linux-2.4.22-1.2097.nptl/fs/nls'
make -C partitions
make[2]: Entering directory `/usr/src/linux-2.4.22-1.2097.nptl/fs/partitions'
make all_targets
make[3]: Entering directory `/usr/src/linux-2.4.22-1.2097.nptl/fs/partitions'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22-1.2097.nptl/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-iwithprefix include -DKBUILD_BASENAME=check  -DEXPORT_SYMTAB -c check.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22-1.2097.nptl/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-iwithprefix include -DKBUILD_BASENAME=mac  -c -o mac.o mac.c
make[2]: *** [first_rule] Segmentation fault
make[2]: Leaving directory `/usr/src/linux-2.4.22-1.2097.nptl/fs/partitions'
make[1]: *** [_subdir_partitions] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2097.nptl/fs'
make: *** [_dir_fs] Error 2



vanilla 2.4.22 kernel with gcc32:
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=vm86  -c -o vm86.o vm86.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=ptrace  -c -o ptrace.o ptrace.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=i8259  -c -o i8259.o i8259.c
gcc: Internal error: Segmentation fault (program as)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[1]: *** [i8259.o] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22/arch/i386/kernel'
make: *** [_dir_arch/i386/kernel] Error 2


# rpm -qa | grep glibc
glibc-2.3.2-98
glibc-kernheaders-2.4-8.24
glibc-headers-2.3.2-98
glibc-devel-2.3.2-98
glibc-common-2.3.2-98

# rpm -qa | grep gcc
compat-gcc-c++-7.3-2.96.118
gcc-c++-3.3.1-6
gcc-gnat-3.3.1-6
libgcc-3.3.1-6
gcc32-3.2.3-6
gcc-3.3.1-6
gcc-java-3.3.1-6
compat-gcc-7.3-2.96.118
gcc-g77-3.3.1-6

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
export CC="gcc32" (I've also edited the Makefile)
cd /usr/src/linux-2.4 (any kernel)
make mrproper
cp configs/[pick one] .config
make oldconfig
make dep
make bzImage (this usually fails)
make modules (this always fails)

Actual Results:  see description

Expected Results:  clean compiles

Additional info:
Comment 1 Dave Jones 2003-10-21 08:45:17 EDT
Looks like a gcc bug. (Or possibly hardware problem, run memtest86 to be on the
safe side).
Comment 2 Jakub Jelinek 2003-10-21 08:48:56 EDT
This doesn't look like gcc bug. It is make which segfaults in the first case
and as which segfaults in the latter case.
If you can reproduce something always on the same file same segfault/error,
we can investigate. But it looks much more like your hardware is toast.
Comment 3 Alan Cox 2004-06-21 13:40:00 EDT
Closing ->hardware

Note You need to log in before you can comment on or make changes to this bug.