Bug 107594 - limburgish language is missing in the Language Configuration Tool
limburgish language is missing in the Language Configuration Tool
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 17:26 EDT by Need Real Name
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 01:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Limburgish, the Netherlands (3.86 KB, text/plain)
2004-01-13 08:18 EST, Kenneth Rohde Christiansen
no flags Details
Limburgish, Belgium (locale li_BE) (3.85 KB, text/plain)
2004-01-13 08:19 EST, Kenneth Rohde Christiansen
no flags Details
li_NL locale (4.01 KB, text/plain)
2004-01-13 08:37 EST, Need Real Name
no flags Details
li_BE locale (3.95 KB, text/plain)
2004-01-13 08:38 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-10-20 17:26:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
The Limburgish language (ISO code: lim, li) is missing from the Language 
Configuration Tool list (as seen on http://fedora.redhat.com/projects/config-
tools/redhat-config-language.html).

This is simply a shame, because this way, people won't use this language; won't 
even know it is available.

At this moment, about 33% of Gnome 2.4 has been translated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Open the Language selector, try selecting Limburgish :-)

Actual Results:  impossible, since Limburgish wasn't on the list

Expected Results:  it should be an option

Additional info:
Comment 1 Brent Fox 2004-01-12 17:52:44 EST
Is Limburgish a valid glibc locale?  I don't see it in the list of
available locales ('locale -a').
Comment 2 Kenneth Rohde Christiansen 2004-01-13 08:16:47 EST
well it should be added to glibc then. I though it had been. Let me
attach the locale definition files. li or lim are official recognized
ISO codes
Comment 3 Kenneth Rohde Christiansen 2004-01-13 08:17:34 EST
http://www.loc.gov/standards/iso639-2/englangn.html

the ISO list of official ISO language codes
Comment 4 Kenneth Rohde Christiansen 2004-01-13 08:18:59 EST
Created attachment 96938 [details]
Limburgish, the Netherlands
Comment 5 Kenneth Rohde Christiansen 2004-01-13 08:19:52 EST
Created attachment 96939 [details]
Limburgish, Belgium (locale li_BE)
Comment 6 Kenneth Rohde Christiansen 2004-01-13 08:25:03 EST
I was pointed out a few mistakes in the locales

please change:

--
% FIXME country_name in Limburgish ?
lang_name "Limburgish"
--

to (in li_NL) 

--
country_name "Nederlandj"
lang_name "Limburgs"
--

and to (in li_BE)
--
country_name "Belsj"
lang_name "Limburgs"
--

Comment 7 Need Real Name 2004-01-13 08:37:38 EST
Created attachment 96940 [details]
li_NL locale
Comment 8 Need Real Name 2004-01-13 08:38:29 EST
Created attachment 96941 [details]
li_BE locale
Comment 9 Brent Fox 2004-01-13 12:40:09 EST
Should we change the component of this bug to glibc?

Once it is added to the list of locales, I can make the necessary
changes to system-config-language.
Comment 10 Kenneth Rohde Christiansen 2004-01-13 16:14:11 EST
if that is the way to get them into glibc, then yes. I tried sending
them to the glibc list and add a bugreport to their bugsystem - but I
have never heard a word back :-(
Comment 11 Brent Fox 2004-01-14 10:15:46 EST
Ok, changing components.
Comment 12 Jakub Jelinek 2004-01-14 10:40:50 EST
Looking at http://sources.redhat.com/ml/libc-alpha/2003-06/msg00132.html
and the following thread I don't see a response from you to
Petter's questions.
LC_IDENTIFICATION/language should be english name of the language
(Limburgish I guess) and LC_IDENTIFICATION/terrirory should be
Netherlands or Belgium.
LC_ADDRESS/country_isbn is I think a number, not string and the other
strings should be written in unicode.  Furthermore they are incorrect,
look what other locales use there.  I think lang_term should be
"<U006C><U0069><U006D>" and lang_lib probably similar (lang_ab/lang_term
are in locale language while lang_lib is in english).
Once you fix this, please post it as a patch to libc-alpha@sources.redhat.com.
Comment 13 Kenneth Rohde Christiansen 2004-01-14 12:15:43 EST
I have never gotten these letters - maybe the mail server was down at
that time. I will look into it.
Comment 14 Ulrich Drepper 2004-08-26 01:10:06 EDT
No answer in 7 months.  Closing.  In any case something which needs to
be brought  up upstream.

Note You need to log in before you can comment on or make changes to this bug.