Red Hat Bugzilla – Bug 10760
rpm-3.0.4 SRPM requires popt-1.5, which is now in rpm-3.0.4
Last modified: 2008-05-01 11:37:55 EDT
popt was integrated with rpm in rpm-3.0.4, before that it was a separate
package (popt-1.4 SRPM was the last one released).
Now, while upgrading 5.x I came across an interesting circular dependency:
rebuilding rpm-3.0.4*.src.rpm requires >= popt-1.5, which can't in turn be
rebuilt, because it's now part of aforementioned rpm package!
This can be avoided by grabbing a binary popt distribution off ftp.rpm.org.
Still, this seems to be something to fix.
Either build with --nodeps, or simply delete the BuildPrereq:.
The dependency is for the 1st popt version with a shared library, which is
needed to build python bindings correctly.