Bug 10760 - rpm-3.0.4 SRPM requires popt-1.5, which is now in rpm-3.0.4
rpm-3.0.4 SRPM requires popt-1.5, which is now in rpm-3.0.4
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-12 15:13 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-13 04:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-04-12 15:13:35 EDT
popt was integrated with rpm in rpm-3.0.4, before that it was a separate
package (popt-1.4 SRPM was the last one released).

Now, while upgrading 5.x I came across an interesting circular dependency:
rebuilding rpm-3.0.4*.src.rpm requires >= popt-1.5, which can't in turn be
rebuilt, because it's now part of aforementioned rpm package!

This can be avoided by grabbing a binary popt distribution off ftp.rpm.org.
Still, this seems to be something to fix.
Comment 1 Jeff Johnson 2000-04-13 04:26:59 EDT
Either build with --nodeps, or simply delete the BuildPrereq:.

The dependency is for the 1st popt version with a shared library, which is
needed to build python bindings correctly.

Note You need to log in before you can comment on or make changes to this bug.