Bug 107635 - Error thrown when adding Controls to a Form (CMS ContentType item)
Error thrown when adding Controls to a Form (CMS ContentType item)
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: content types (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 108447 109973
  Show dependency treegraph
 
Reported: 2003-10-21 11:51 EDT by Richard Su
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-10 15:01:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Su 2003-10-21 11:51:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Description of problem:
Adding any type of controls (textfield, checkbox group, textarea, etc..)
generates this error:

An unexpected error has occurred	

An unexpected error has occurred. If this continues to be a problem for you
please contact the administrators of the site quoting the following:

CCM issue report code: 172.16.64.132:4186bfaf:f85f52f314

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: 172.16.64.132:4186bfaf:f85f52f314 -*-*-*-
-*-*-*- Message: cannot find label for WidgetLabel -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate
Accept-Language: en-us,en;q=0.5
Connection: keep-alive
Content-Length: 649
Content-Type: application/x-www-form-urlencoded
Cookie: JSESSIONID=aAykW-DBWck6;
ad_user_login=1021!1161357840720!4rG+fw3GBFb184wlFfQYlQ==
Host: rwsu.boston.redhat.com:9003
Keep-Alive: 300
Referer: http://rwsu.boston.redhat.com:9003/ccm/forms/admin/item.jsp
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: aAykW-DBWck6 (expires: -1)
ad_user_login: 1021!1161357840720!4rG+fw3GBFb184wlFfQYlQ== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.bebop.FormProcessException: cannot find label for WidgetLabel
	at
com.arsdigita.formbuilder.ui.editors.WidgetLabelForm.processWidgets(WidgetLabelForm.java:127)
	at
com.arsdigita.formbuilder.ui.editors.TextFieldForm.processWidgets(TextFieldForm.java:151)
	at
com.arsdigita.formbuilder.ui.editors.WidgetForm$WidgetFormProcessListener.process(WidgetForm.java:276)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:491)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:465)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:368)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:280)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:82)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:77)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:294)
	at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java:60)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:177)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:206)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:219)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:63)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:143)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:111)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:105)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:94)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:229)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:214)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:200)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:132)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:513)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/forms/admin/item.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
file.encoding: ANSI_X3.4-1968
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/jaas.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/jce.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/sunjce_provider.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/xerces.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/xalan.jar:/ora8/m01/app/oracle/product/9.2/jdbc/lib/classes12.zip:/usr/share/pgsql/java/rh-pgsql-jdbc2.jar:/opt/resin/2.1.4/lib/jaxp.jar:/opt/resin/2.1.4/lib/dom.jar:/opt/resin/2.1.4/lib/jdbc2_0-stdext.jar:/opt/resin/2.1.4/lib/jdbc-mysql.jar:/opt/resin/2.1.4/lib/jndi.jar:/opt/resin/2.1.4/lib/jmx.jar:/opt/resin/2.1.4/lib/jta-spec1_0_1.jar:/opt/resin/2.1.4/lib/resin.jar:/opt/resin/2.1.4/lib/sax.jar:/opt/resin/2.1.4/lib/webutil.jar:/usr/local/java/lib/tools.jar:/usr/local/java/jre/lib/rt.jar:/opt/resin/2.1.4/lib/jsdk23.jar
java.class.version: 46.0
java.compiler: jitc
java.ext.dirs: /usr/local/java/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20030618 (JIT enabled: jitc)
java.home: /usr/local/java/jre
java.io.tmpdir: /tmp
java.library.path:
/usr/local/java/jre/bin:/usr/local/java/jre/bin/classic:/ora8/m01/app/oracle/product/9.2/lib:/lib/usr/lib:libexec:/usr/lib
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20030618 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory: com.icl.saxon.TransformerFactoryImpl
line.separator: 

os.arch: x86
os.name: Linux
os.version: 2.4.20-20.8
path.separator: :
PreferredXSLTTransformer: SAXON
resin.home: /opt/resin/2.1.4
sun.boot.class.path:
/usr/local/java/jre/lib/rt.jar:/usr/local/java/jre/lib/i18n.jar:/usr/local/java/jre/classes
sun.boot.library.path: /usr/local/java/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /usr/opt/resin/2.1.4
user.home: /home/rwsu
user.language: en
user.name: rwsu
user.timezone: America/New_York
-*-*-*-*-*- End Error Report -*-*-*-*-*-


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a new Form in the form content section
2. Add a new control and fill in all fields

    

Expected Results:  No errors.

Additional info:
Comment 1 Jon Orris 2003-12-04 15:46:33 EST
Probably a dup of 109973. Marking as blocking to double-check it's
tested before 6.0.1 release.
Comment 2 Richard Su 2003-12-08 12:01:05 EST
After integrating 38130 as referenced by 109973, I'm now seeing this
error:

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: 172.16.64.132:e2c80f3:f956c5c240 -*-*-*-
-*-*-*- Message:  (root cause: object :
[com.arsdigita.auditing.BasicAuditTrail:{id=10001}] already exists)
-*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/x-shockwave-flash, application/vnd.ms-powerpoint,
application/vnd.ms-excel, application/msword, */*
Accept-Encoding: gzip, deflate
Accept-Language: en-us
Cache-Control: no-cache
Connection: Keep-Alive
Content-Length: 1096
Content-Type: application/x-www-form-urlencoded
Cookie: ad_user_login=2008!1162491279932!sXHm/KcE6jpcrSFx/ZbLTw==;
CP=null*; JSESSIONID=aKgYCiJR2r9c
Host: rwsu.boston.redhat.com:9003
Referer: http://rwsu.boston.redhat.com:9003/ccm/content/admin/item.jsp
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

-*-*-*- Section: Cookies -*-*-*-
ad_user_login: 2008!1162491279932!sXHm/KcE6jpcrSFx/ZbLTw== (expires: -1)
CP: null* (expires: -1)
JSESSIONID: aKgYCiJR2r9c (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.UniqueConstraintException:  (root cause:
com.redhat.persistence.DuplicateObjectException: object :
[com.arsdigita.auditing.BasicAuditTrail:{id=10001}] already exists)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:129)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:109)
	at com.arsdigita.persistence.DataObjectImpl.set(DataObjectImpl.java:274)
	at com.arsdigita.domain.DomainObject.set(DomainObject.java:340)
	at com.arsdigita.auditing.BasicAuditTrail.setID(BasicAuditTrail.java:155)
	at
com.arsdigita.auditing.AuditingObserver.afterSave(AuditingObserver.java:81)
	at
com.arsdigita.domain.ObservableDomainObject$ProxyObserver.afterSave(ObservableDomainObject.java:196)
	at com.arsdigita.persistence.AfterSaveEvent.doInvoke(DataEvent.java:206)
	at com.arsdigita.persistence.DataEvent.invoke(DataEvent.java(Compiled
Code))
	at
com.arsdigita.persistence.DataObjectImpl.fireObserver(DataObjectImpl.java(Compiled
Code))
	at com.arsdigita.persistence.DataEvent.fire(DataEvent.java(Inlined
Compiled Code))
	at
com.arsdigita.persistence.Session$FlushEventProcessor.flush(Session.java(Compiled
Code))
	at com.redhat.persistence.Session.process(Session.java(Compiled Code))
	at com.redhat.persistence.Session.flushInternal(Session.java(Compiled
Code))
	at com.redhat.persistence.Session.flush(Session.java(Compiled Code))
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:406)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at
com.arsdigita.formbuilder.ui.editors.WidgetForm$WidgetFormProcessListener.process(WidgetForm.java:279)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:491)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:465)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:368)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:280)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:82)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:77)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:294)
	at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java:60)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at
com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:180)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:209)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:222)
	at
com.arsdigita.cms.dispatcher.FileDispatcher$1.excurse(FileDispatcher.java:68)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:82)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:77)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:71)
	at
com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:143)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:111)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:105)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:94)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:229)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:214)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:200)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:132)
	at
com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:134)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:513)
Root cause: 
com.redhat.persistence.DuplicateObjectException: object :
[com.arsdigita.auditing.BasicAuditTrail:{id=10001}] already exists
	at com.redhat.persistence.Expander.onCreate(Expander.java:105)
	at com.redhat.persistence.CreateEvent.dispatch(CreateEvent.java:39)
	at com.redhat.persistence.Expander.expand(Expander.java(Compiled Code))
	at com.redhat.persistence.Session.create(Session.java:211)
	at com.arsdigita.persistence.DataObjectImpl.set(DataObjectImpl.java:268)
	at com.arsdigita.domain.DomainObject.set(DomainObject.java:340)
	at com.arsdigita.auditing.BasicAuditTrail.setID(BasicAuditTrail.java:155)
	at
com.arsdigita.auditing.AuditingObserver.afterSave(AuditingObserver.java:81)
	at
com.arsdigita.domain.ObservableDomainObject$ProxyObserver.afterSave(ObservableDomainObject.java:196)
	at com.arsdigita.persistence.AfterSaveEvent.doInvoke(DataEvent.java:206)
	at com.arsdigita.persistence.DataEvent.invoke(DataEvent.java(Compiled
Code))
	at
com.arsdigita.persistence.DataObjectImpl.fireObserver(DataObjectImpl.java(Compiled
Code))
	at com.arsdigita.persistence.DataEvent.fire(DataEvent.java(Inlined
Compiled Code))
	at
com.arsdigita.persistence.Session$FlushEventProcessor.flush(Session.java(Compiled
Code))
	at com.redhat.persistence.Session.process(Session.java(Compiled Code))
	at com.redhat.persistence.Session.flushInternal(Session.java(Compiled
Code))
	at com.redhat.persistence.Session.flush(Session.java(Compiled Code))
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:406)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at
com.arsdigita.formbuilder.ui.editors.WidgetForm$WidgetFormProcessListener.process(WidgetForm.java:279)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:491)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:465)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:368)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:280)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:82)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:77)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:294)
	at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java:60)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at
com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:180)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:209)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:222)
	at
com.arsdigita.cms.dispatcher.FileDispatcher$1.excurse(FileDispatcher.java:68)
	at com.arsdigita.cms.CMSExcursion$1.excurse(CMSExcursion.java:82)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:77)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:71)
	at
com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:143)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:111)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:105)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:94)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:229)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:214)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:200)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:132)
	at
com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:134)
	at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:513)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content/admin/item.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
com.arsdigita.london.navigation.DefaultContentSection: /content/
file.encoding: ANSI_X3.4-1968
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/jaas.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/jce.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/sunjce_provider.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/xerces.jar:/var/ccm-devel/web/rwsu/soa/webapps/ccm/WEB-INF/lib/xalan.jar:/ora8/m01/app/oracle/product/9.2/jdbc/lib/classes12.zip:/usr/share/pgsql/java/rh-pgsql-jdbc2.jar:/opt/resin/2.1.4/lib/jaxp.jar:/opt/resin/2.1.4/lib/dom.jar:/opt/resin/2.1.4/lib/jdbc2_0-stdext.jar:/opt/resin/2.1.4/lib/jdbc-mysql.jar:/opt/resin/2.1.4/lib/jndi.jar:/opt/resin/2.1.4/lib/jmx.jar:/opt/resin/2.1.4/lib/jta-spec1_0_1.jar:/opt/resin/2.1.4/lib/resin.jar:/opt/resin/2.1.4/lib/sax.jar:/opt/resin/2.1.4/lib/webutil.jar:/usr/local/java/lib/tools.jar:/usr/local/java/jre/lib/rt.jar:/opt/resin/2.1.4/lib/jsdk23.jar
java.class.version: 46.0
java.compiler: jitc
java.ext.dirs: /usr/local/java/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20030618 (JIT
enabled: jitc)
java.home: /usr/local/java/jre
java.io.tmpdir: /tmp
java.library.path:
/usr/local/java/jre/bin:/usr/local/java/jre/bin/classic:/ora8/m01/app/oracle/product/9.2/lib:/lib/usr/lib:libexec:/usr/lib
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20030618 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory:
org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
com.icl.saxon.TransformerFactoryImpl
line.separator: 

os.arch: x86
os.name: Linux
os.version: 2.4.20-24.8
path.separator: :
PreferredXSLTTransformer: SAXON
resin.home: /opt/resin/2.1.4
sun.boot.class.path:
/usr/local/java/jre/lib/rt.jar:/usr/local/java/jre/lib/i18n.jar:/usr/local/java/jre/classes
sun.boot.library.path: /usr/local/java/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /usr/opt/resin/2.1.4
user.home: /home/rwsu
user.language: en
user.name: rwsu
user.timezone: America/New_York
-*-*-*-*-*- End Error Report -*-*-*-*-*-


 
 
 
Comment 3 Daniel Berrange 2003-12-09 11:20:09 EST
It looks like this is related to bug 109978.
Comment 4 Richard Su 2003-12-09 14:54:47 EST
Archit pulled in the fix from bug 109978 into changelist 38130. I've
already integrated that changelist, and am seeing the second error I
noted above.

Comment 5 Archit Shah 2003-12-09 16:46:01 EST
the second error is an observer bug. fixed at 38641 (6.0.x) and 38642
(dev).

Note You need to log in before you can comment on or make changes to this bug.