Bug 107655 - Requires error
Requires error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 15:06 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-27 10:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
-vv output with nessus and nessus-server preinstalled (2.52 KB, text/plain)
2003-10-21 17:35 EDT, Gene Czarcinski
no flags Details
-v output with nessus, nessus-server and nessus-devel installed at same time (8.66 KB, text/plain)
2003-10-21 17:36 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2003-10-21 15:06:08 EDT
Description of problem:
I am attempting to build and then install a set of packages (specifically
nessus).  This is a set of src packages rather than the single src package
kluge:  libnessus (built and installed first), libnasl (build and installed
next), and finally nessus (built and install last).

libnessus produces libnessus and libnessus-devel (requires libnessus) and goes OK.

libnasl produces libnasl, nasl, and libnasl-devel (which requires libnasl) ...
everything goes OK.

nessus produces nessus (the client), nessus-server, and nessus-devel (which
requires nessus-server).  When I go to install, nessus and nessus-server install
OK but I get an error trying to install nessus-devel:

error: Failed dependencies:
        nessus-server = 2.0.8a-gc1.1 is needed by nessus-devel-2.0.8a-gc1.1

All of these build and install OK ok RHL9.

In addition, I get the same error try to install the packages built on RHL9.
Comment 1 Gene Czarcinski 2003-10-21 15:07:28 EDT
BTW, the error for nessus-devel is the same if I first install nessus and
nessus-server and then (separately) do nessus-devel or if I do it with one command.
Comment 2 Jeff Johnson 2003-10-21 17:14:56 EDT
Can you attach the detailed -vv output please?
Comment 3 Gene Czarcinski 2003-10-21 17:35:01 EDT
Created attachment 95362 [details]
-vv output with nessus and nessus-server preinstalled
Comment 4 Gene Czarcinski 2003-10-21 17:36:02 EDT
Created attachment 95363 [details]
-v output with nessus, nessus-server and nessus-devel installed at same time
Comment 5 Gene Czarcinski 2003-10-22 17:05:41 EDT
If you need copies of the nessus packages themselves, I can upload them to a
server I have.
Comment 6 Gene Czarcinski 2003-10-27 14:29:53 EST
problem still exists.

Is there any info you need?
Comment 7 Gene Czarcinski 2003-10-27 15:27:34 EST
I have put the packages on a server accessable via anonymous ftp at
ftp://czarc.net (both i386 and src)

First install the libnessus packages, then the libnasl packages, and finally the
nessus packages.
Comment 8 Gene Czarcinski 2003-11-17 13:55:40 EST
Anything new on this ... the problem still exists.

I just rebuilt and did:
rpm -Uvh nessus-2.0.8a-gc1.1.i386.rpm nessus-server-2.0.8a-gc1.1.i386.rpm
Preparing...               
########################################### [100%]
   1:nessus-server         
########################################### [ 50%]
   2:nessus                
########################################### [100%]

Then I did:
rpm -Uvh nessus-devel-2.0.8a-gc1.1.i386.rpm error: Failed dependencies:
        nessus-server = 2.0.8a-gc1.1 is needed by
nessus-devel-2.0.8a-gc1.1

The spec file contains the following for the nessus-devel:

%package devel
Group: Development/Libraries
Summary: Nessus static libraries and header files.
Requires: nessus-server = %{version}-%{release}

%description devel
Developement libraries and headers for Nessus, the remote security
scanner.
You will need this package to build new plugins or to update your existing
ones.

I can simply get around the problem by repackaging the -devel stuff
with the -server package but this appears to me to be a bug with rpm.

Comment 9 Jeff Johnson 2003-12-27 10:05:51 EST
Not a bug, epoch's must be specified where needed:

--- nessus-2.0.8a-8.gc1.spec.orig       2003-12-27 10:06:28.205285504
-0500
+++ nessus-2.0.8a-8.gc1.spec    2003-12-27 10:07:14.538333229 -0500
@@ -51,7 +51,7 @@
 %package devel
 Group: Development/Libraries
 Summary: Nessus static libraries and header files.
-Requires: nessus-server = %{version}-%{release}
+Requires: nessus-server = %{epoch}:%{version}-%{release}
  
 %description devel
 Developement libraries and headers for Nessus, the remote security
scanner.

Note You need to log in before you can comment on or make changes to this bug.