Bug 107681 - 2.6 kernel and filesystem RPMs disagree on dependencies
2.6 kernel and filesystem RPMs disagree on dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 19:26 EDT by Tom Wood
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 03:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2003-10-21 19:26:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
Arjan's 2.6 test 8 and filesystem 2.2.1-5 disagree on something about
/lib/modules.  Bill Nottingham seemed to think it was permissions on
fedora-test-list.

/lib/modules is 644 owned by root.root currently (without 2.6.0-0-test8 in place)

Version-Release number of selected component (if applicable):
2.6.0-0-test8.1.62 and filesystem-2.2.1-5

How reproducible:
Always

Steps to Reproduce:
1. Install fedora core test 3 and fully up2date it.
2. Try to install 2.6.0-0-test8 from Arjan.
3. Watch it complain.
    

Actual Results:  No install of 2.6 test8

Expected Results:  Install of 2.6 test8.

Additional info:

[root@fed2 root]# up2date -uf
 
Fetching package list for channel: arjan-2.6-kernel-i386-kernel...
 
Fetching http://people.redhat.com/~arjanv/2.5//base/pkglist.kernel.bz2...
gh1
gh2
gh3
########################################
 
Fetching package list for channel: rawhide...
 
Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################
 
Fetching Obsoletes list for channel: arjan-2.6-kernel-i386-kernel...
 
Fetching Obsoletes list for channel: rawhide...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
kernel                                  2.6.0          0.test8.1.62        i686
 
 
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
file /lib/modules from install of kernel-2.6.0-0.test8.1.62 conflicts with file
from package filesystem-2.2.1-5
Comment 1 Tom Wood 2003-10-21 20:38:23 EDT
Well, something else is amiss.  Downloading the heretofore offending kernel and
rpm installing didn't trigger the problem.  After doing so, there's no
difference in /lib/modules itself, either.

Looks like the component of this bug needs to be changed to up2date IMHO.
Comment 2 Sahil Verma 2004-03-20 22:41:38 EST
Please close as NOTABUG or change module to up2date.

Note You need to log in before you can comment on or make changes to this bug.