This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 107696 - gkrellm text scrambled by default in Japanese environment
gkrellm text scrambled by default in Japanese environment
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gkrellm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
: i18n
: 57012 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 03:19 EDT by Nakai
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 11:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot (16.17 KB, image/png)
2003-10-22 03:19 EDT, Nakai
no flags Details

  None (edit)
Description Nakai 2003-10-22 03:19:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When user run gkrellm after fresh install,
it shows scrambled text.

Version-Release number of selected component (if applicable):
gkrellm-2.1.20-3

How reproducible:
Always

Steps to Reproduce:
1. Run gkrellm with ja_JP.UTF-8 locale
2. Scrambled.
3.
    

Actual Results:  Scrambled text

Expected Results:  Readable Japanese text

Additional info:

User must be able to see correct Japanese text
without any special font settings or operation knowledge.
Comment 1 Nakai 2003-10-22 03:19:54 EDT
Created attachment 95378 [details]
screen shot
Comment 2 Bill Nottingham 2003-10-22 11:30:35 EDT
gkrellm uses gtk1, by any chance?
Comment 3 Bill Nottingham 2003-10-22 11:33:24 EDT
No, it uses gtk2. Hm.
Comment 4 Nakai 2003-10-23 03:12:40 EDT
gkrellm still has gtk 1.2 style XLFD setting dialog, so it is supposed to
using gdk_font_load/gdk_fontset_load code inside, and not well ported to
pango.
Comment 5 Nakai 2004-03-11 07:01:54 EST
Still not fixed in Fedora Core 2 test1
Comment 6 Nakai 2004-04-07 13:49:08 EDT
*** Bug 57012 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2004-06-01 05:20:11 EDT
Please try gkrellm-2.2.0-1 from rawhide tomorrow.  It now uses pango
to render text, so this should theoretically be fixed.  CLOSE or
REOPEN after you have tested.
Comment 8 Nakai 2004-06-01 07:10:48 EDT
The upstream source code works for me.
date format is still wrong but this is another issue
Comment 9 Nakai 2004-06-01 11:47:12 EDT
Confirmed with gkrellm-2.2.0-1.
Thank you!

Note You need to log in before you can comment on or make changes to this bug.